Last Comment Bug 713887 - Javascript error when using the menu quit to quit fennec
: Javascript error when using the menu quit to quit fennec
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: 12 Branch
: ARM Android
: P4 normal (vote)
: Firefox 12
Assigned To: Mark Finkle (:mfinkle) (use needinfo?)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-28 10:01 PST by Naoki Hirata :nhirata (please use needinfo instead of cc)
Modified: 2012-01-11 20:59 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
verified


Attachments
patch (881 bytes, patch)
2011-12-28 10:30 PST, Mark Finkle (:mfinkle) (use needinfo?)
mbrubeck: review+
dougt: approval‑mozilla‑aurora+
Details | Diff | Review

Description Naoki Hirata :nhirata (please use needinfo instead of cc) 2011-12-28 10:01:09 PST
1. launch fennec nightly
2. go to the fennec menu and quit
3. look at logcat

Expected: no error messages
Actual:
12-28 09:58:13.832: E/GeckoConsole(19735): [JavaScript Error: "got quit quit message" {file: "chrome://browser/content/browser.js" line: 425}]

Note:
Nexus S; Android 2.3; 20111228
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-28 10:30:04 PST
Created attachment 584591 [details] [diff] [review]
patch

This is not really an error, just a bad log message. This patch removes the log.
Comment 2 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-29 20:36:47 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/d0e07813ae6e
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) (Away until 6/13) 2011-12-30 04:51:53 PST
https://hg.mozilla.org/mozilla-central/rev/d0e07813ae6e
Comment 4 Aaron Train [:aaronmt] 2011-12-30 07:42:04 PST
Samsung Nexus S (Android 4.0.3)
20111230040819
http://hg.mozilla.org/mozilla-central/rev/9fdaea5d67e2
Comment 5 Brad Lassey [:blassey] (use needinfo?) 2012-01-11 19:20:29 PST
Comment on attachment 584591 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Useless debug spew. Other patches don't apply
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
none
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-11 20:59:28 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/c23ff2352830

Note You need to log in before you can comment on or make changes to this bug.