Closed Bug 713904 Opened 10 years ago Closed 10 years ago

New background color for image pages unusable

Categories

(Firefox :: General, defect)

12 Branch
x86
Windows 7
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 713230

People

(Reporter: zao, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:12.0a1) Gecko/20111228 Firefox/12.0a1
Build ID: 20111228031049

Steps to reproduce:

I opened a PNG or SVG file, expecting to see it against the usual white background.


Actual results:

They display against some dark gray background, making them pretty much unreadable.


Expected results:

It should be showing against the usual background color, not the forced dark gray from bug 376997. I echo the ignored comments in that bug that the color should be configurable and that the default should be one for which alpha composition makes sense. Pretty much all images authored for web usage are designed with a white matte as reference.
Depends on: 376997
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 376997
(In reply to Lars Viklund from comment #0)
> I opened a PNG or SVG file, expecting to see it against the usual white
> background.

Lars: do you really see a non-white-background with an SVG file?

SVG should still use the usual white background, because SVG is treated as a document (not an image) when viewed directly.  That's how it behaves in my nightly, at least.  If you see other behavior with SVG, that would be very interesting...

Also, :emk, I don't think it makes sense to dupe this to the bug that caused it.  Bug 713555 sounds like a better dupe-match to me (using an adaptive (configurable?) background color).  Duping to that instead.
Duplicate of bug: 713555
(In reply to Daniel Holbert [:dholbert] from comment #2)
> Also, :emk, I don't think it makes sense to dupe this to the bug that caused
> it.  Bug 713555 sounds like a better dupe-match to me (using an adaptive
> (configurable?) background color).  Duping to that instead.
Sorry, I intended bug 713230.
(In reply to Daniel Holbert [:dholbert] from comment #2)
> (In reply to Lars Viklund from comment #0)
> > I opened a PNG or SVG file, expecting to see it against the usual white
> > background.
> 
> Lars: do you really see a non-white-background with an SVG file?

I'm sorry, I was mislead by an image linked that ended in _svg.png
SVG files are thankfully working as intended.
Duplicate of bug: 713230
You need to log in before you can comment on or make changes to this bug.