Last Comment Bug 713922 - Don't allow user to use empty password for master password
: Don't allow user to use empty password for master password
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: P3 normal (vote)
: ---
Assigned To: Wesley Johnston (:wesj)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-28 12:35 PST by Tony Chung [:tchung]
Modified: 2012-07-19 19:19 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
verified
11+


Attachments
Patch (1.62 KB, patch)
2012-01-06 12:32 PST, Wesley Johnston (:wesj)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Tony Chung [:tchung] 2011-12-28 12:35:55 PST
We need to add some inline messaging when a new master password textboxes are empty.  User can currently hit OK with blank entries, and nothing happens.

Repro:
1) fennec nightly, 12-28-2011 build, SGS2
2) launch prefs, check the Use master password button
3) When the dialog box appears with the password / confirm password textboxes, leave it blank and hit OK.   Alternately, skipping the password box, and just typing in confirmation does the same
4) verify no inline messages or action required to the user.  

Expected:
- an inline message telling the user to fill out both boxes.  also disabling OK if there's no entries.

Actual;
- no messaging
Comment 1 Mark Finkle (:mfinkle) (use needinfo?) 2011-12-29 12:55:15 PST
Changing to "Don't allow user to tap 'OK' if the password fields are blank"
Comment 2 Wesley Johnston (:wesj) 2012-01-06 12:32:42 PST
Created attachment 586520 [details] [diff] [review]
Patch
Comment 3 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-06 12:34:44 PST
Comment on attachment 586520 [details] [diff] [review]
Patch

Make sure you test this by adding, removing and re-adding a master password. Just to make sure the dialogs work in cyclical usage.
Comment 4 Wesley Johnston (:wesj) 2012-01-18 08:58:37 PST
https://hg.mozilla.org/mozilla-central/rev/19af1aac33ac
Comment 5 Wesley Johnston (:wesj) 2012-01-20 11:08:45 PST
Comment on attachment 586520 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): landing of mp on trunk
User impact if declined: Very low. Users will be able to attempt to use an empty mp. it will fail
Testing completed (on m-c, etc.): on m-c for a bit now
Risk to taking this patch (and alternatives if risky): very low risk
Comment 6 Alex Keybl [:akeybl] 2012-01-20 12:59:17 PST
Comment on attachment 586520 [details] [diff] [review]
Patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 7 Brad Lassey [:blassey] (use needinfo?) 2012-01-20 13:46:14 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/8508d6cc7e46
Comment 8 Paul Feher 2012-03-07 06:00:01 PST
Verified fixed on:
Nightly Fennec 13.0a1 (2012-03-06)
Device: HTC Desire Z
OS: Android 2.3.3

The OK button is not active until the two fields: password and confirm password are not identical and different of null.
Comment 9 Arkady Blyakher [:rkd] 2012-07-19 19:19:07 PDT
*** Bug 733754 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.