Last Comment Bug 713935 - Fix debug builds on gonk due not having HAVE_SYS_UIO_H defined
: Fix debug builds on gonk due not having HAVE_SYS_UIO_H defined
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: unspecified
: All Gonk (Firefox OS)
: -- normal (vote)
: mozilla12
Assigned To: Michael Wu [:mwu]
:
Mentors:
: 714144 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-28 13:25 PST by Michael Wu [:mwu]
Modified: 2011-12-30 04:56 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Define HAVE_SYS_UIO_H on gonk in configure.in (295 bytes, patch)
2011-12-28 13:25 PST, Michael Wu [:mwu]
khuey: review+
Details | Diff | Splinter Review

Description Michael Wu [:mwu] 2011-12-28 13:25:14 PST
Created attachment 584628 [details] [diff] [review]
Define HAVE_SYS_UIO_H on gonk in configure.in

Without HAVE_SYS_UIO_H defined, some system headers get confused and try to redefine things they don't need to.
Comment 1 Michael Wu [:mwu] 2011-12-29 12:15:09 PST
*** Bug 714144 has been marked as a duplicate of this bug. ***
Comment 3 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-12-30 04:56:27 PST
https://hg.mozilla.org/mozilla-central/rev/6d050439f687

Note You need to log in before you can comment on or make changes to this bug.