Have browser.sessionstore.max_resumed_crashes be 0 by default.

RESOLVED WONTFIX

Status

()

--
enhancement
RESOLVED WONTFIX
7 years ago
4 years ago

People

(Reporter: shadab_56, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Opened 12 tabs of one website, power failure, PC turned off immediately. Powered it on. Ran Firefox.


Actual results:

All 12 tabs of one website started loading without asking me. My account go blocked for a while due simultaneous hits one website.


Expected results:

It should have asked me. Then I researched for 30 mins and solved by disabling the "resume from crash option" in about:config.
This option should be in options dialog, I think, and it must ask to reload all tabs.

Comment 1

7 years ago
It asks on the second crash, that's browser.sessionstore.max_resumed_crashes
Setting it to 0 will ask without trying to resume once.
Adjusting the bug title to request that be the value by default.
Severity: normal → enhancement
Component: General → Session Restore
OS: Windows 7 → All
QA Contact: general → session.restore
Hardware: x86 → All
Summary: resume from crash option → Have browser.sessionstore.max_resumed_crashes be 0 by default.
Version: 9 Branch → Trunk

Comment 2

7 years ago
Workaround for the "account go blocked for a while" is to tick
"Don't load tabs until selected" in the "General" section of options.
(Reporter)

Comment 3

7 years ago
The option "Don't load tabs until selected" is not available in my version 9.0.1 of FF.
(Reporter)

Comment 4

7 years ago
(In reply to Mardeg from comment #2)
> Workaround for the "account go blocked for a while" is to tick
> "Don't load tabs until selected" in the "General" section of options.

The option "Don't load tabs until selected" is not available in my version 9.0.1 of FF.
We won't be making that pref 0 by default.

shadab_56: The checkbox should be there. If it's not enabled, you can change the browser.sessionstore.restore_on_demand preference to true in about config or right there in the UI. In the UI, first change "when firefox starts" to "show windows & tabs...", then check the box, then put your "when firefox starts" pref back to what it was.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 6

7 years ago
Yes, you are right. I always use "Show blank page" option, that's why missed the check box.

Followed the steps, issue resolved.

Thanks
(Reporter)

Comment 7

7 years ago
Sorry, its partially resolved. It bothered me multiple times.

The thing is, for all users who use "Show blank page" when FF starts, FF will auto load all tabs after crash, WITHOUT ASKING.

I think it must ask the user for a final click, like chrome does.
(In reply to shadab_56@yahoo.com from comment #7)
> Sorry, its partially resolved. It bothered me multiple times.
> 
> The thing is, for all users who use "Show blank page" when FF starts, FF
> will auto load all tabs after crash, WITHOUT ASKING.
> 
> I think it must ask the user for a final click, like chrome does.

We think the opposite, at least historically and currently. If you crashed then you probably want to get right back to what you were doing, not go through a process of extra clicks & waiting. We do our best to put the user right back into the state they were (cookies, formdata, etc).

There are edge cases that don't work for some people and so we do at least provide a way to make your situation better, but we think our default behavior works well for _most_ people.

Updated

4 years ago
Duplicate of this bug: 820983
You need to log in before you can comment on or make changes to this bug.