Last Comment Bug 714027 - Devtools sidebar box has a weird background when opened on Windows
: Devtools sidebar box has a weird background when opened on Windows
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Inspector (show other bugs)
: 12 Branch
: All Windows 7
: -- normal (vote)
: Firefox 12
Assigned To: Michael Ratcliffe PTO -> Fri, 24 Jun 2016 [:miker] [:mratcliffe]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-29 01:29 PST by Victor Porof [:vporof][:vp]
Modified: 2012-01-16 02:27 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
screen1 (164.49 KB, image/png)
2011-12-29 01:29 PST, Victor Porof [:vporof][:vp]
no flags Details
screen2 (152.34 KB, image/png)
2011-12-29 01:30 PST, Victor Porof [:vporof][:vp]
no flags Details
Fix (1.94 KB, patch)
2012-01-09 04:36 PST, Michael Ratcliffe PTO -> Fri, 24 Jun 2016 [:miker] [:mratcliffe]
dao+bmo: review+
mihai.sucan: review+
Details | Diff | Review

Description Victor Porof [:vporof][:vp] 2011-12-29 01:29:12 PST
Created attachment 584714 [details]
screen1

When opened, the Style sidebar has a blueish background for a second before loading the content. This happens every time the sidebar is shown.
Comment 1 Victor Porof [:vporof][:vp] 2011-12-29 01:30:21 PST
Created attachment 584715 [details]
screen2
Comment 2 Paul Rouget [:paul] 2012-01-03 05:21:03 PST
Is it like a transparent background? Do we see the window that is behind the Firefox window?
Comment 3 Victor Porof [:vporof][:vp] 2012-01-03 05:34:08 PST
(In reply to Paul Rouget [:paul] from comment #2)
> Is it like a transparent background? Do we see the window that is behind the
> Firefox window?

No, it's opaque.
Comment 4 Michael Ratcliffe PTO -> Fri, 24 Jun 2016 [:miker] [:mratcliffe] 2012-01-05 10:56:02 PST
I can take a look at this tomorrow.
Comment 5 Michael Ratcliffe PTO -> Fri, 24 Jun 2016 [:miker] [:mratcliffe] 2012-01-09 03:01:48 PST
I can reproduce this and the background is transparent (the same as the title bar). The problem is that if we put e.g. a white background behind the tools before they are initialized then it either causes more flicker. Maybe we could use a white background for each tool until it is fully initialized.
Comment 6 Michael Ratcliffe PTO -> Fri, 24 Jun 2016 [:miker] [:mratcliffe] 2012-01-09 04:36:27 PST
Created attachment 586957 [details] [diff] [review]
Fix
Comment 7 Mihai Sucan [:msucan] 2012-01-09 13:40:22 PST
Comment on attachment 586957 [details] [diff] [review]
Fix

Looks good! Thanks for the fix!
Comment 8 Rob Campbell [:rc] (:robcee) 2012-01-14 09:57:08 PST
https://hg.mozilla.org/integration/fx-team/rev/88bbbc7d113a
Comment 9 Tim Taubert [:ttaubert] 2012-01-16 02:27:42 PST
https://hg.mozilla.org/mozilla-central/rev/88bbbc7d113a

Note You need to log in before you can comment on or make changes to this bug.