Closed Bug 714027 Opened 8 years ago Closed 8 years ago

Devtools sidebar box has a weird background when opened on Windows

Categories

(DevTools :: Inspector, defect)

12 Branch
All
Windows 7
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED
Firefox 12

People

(Reporter: vporof, Assigned: miker)

Details

Attachments

(3 files)

Attached image screen1
When opened, the Style sidebar has a blueish background for a second before loading the content. This happens every time the sidebar is shown.
Attached image screen2
Is it like a transparent background? Do we see the window that is behind the Firefox window?
(In reply to Paul Rouget [:paul] from comment #2)
> Is it like a transparent background? Do we see the window that is behind the
> Firefox window?

No, it's opaque.
I can take a look at this tomorrow.
Assignee: nobody → mratcliffe
Status: NEW → ASSIGNED
I can reproduce this and the background is transparent (the same as the title bar). The problem is that if we put e.g. a white background behind the tools before they are initialized then it either causes more flicker. Maybe we could use a white background for each tool until it is fully initialized.
Attached patch FixSplinter Review
Attachment #586957 - Flags: review?(mihai.sucan)
Attachment #586957 - Flags: review?(dao)
Whiteboard: [has-patch]
Attachment #586957 - Flags: review?(dao) → review+
Comment on attachment 586957 [details] [diff] [review]
Fix

Looks good! Thanks for the fix!
Attachment #586957 - Flags: review?(mihai.sucan) → review+
Whiteboard: [has-patch] → [land-in-fx-team]
https://hg.mozilla.org/integration/fx-team/rev/88bbbc7d113a
Whiteboard: [land-in-fx-team] → [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/88bbbc7d113a
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 12
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.