Last Comment Bug 714140 - Charlton Company trademark notice can be removed from About dialog
: Charlton Company trademark notice can be removed from About dialog
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86_64 Windows 7
: -- normal (vote)
: Firefox 12
Assigned To: Justin Dolske [:Dolske]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-29 11:57 PST by Liz Compton [:liz]
Modified: 2012-01-23 13:25 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v.1 (2.25 KB, patch)
2011-12-29 16:20 PST, Justin Dolske [:Dolske]
gavin.sharp: review+
Details | Diff | Review
Screenshot (335.28 KB, image/png)
2011-12-29 17:28 PST, Justin Dolske [:Dolske]
no flags Details
requested modification to trolololo section (303.38 KB, image/png)
2012-01-03 07:59 PST, Kev Needham [:kev]
no flags Details

Description Liz Compton [:liz] 2011-12-29 11:57:39 PST
Our obligation to include a trademark attribution for Charlton Company expired on November 23, 2011. The notice can be removed from all future versions of Firefox.
Comment 1 Justin Dolske [:Dolske] 2011-12-29 16:20:26 PST
Created attachment 584881 [details] [diff] [review]
Patch v.1

Essentially undoing gavin's patch from bug 616193.

The CSS for .trademark-label isn't needed, because the theme already twiddles things for #trademark. I'll attach a screenshot after my build finishes.
Comment 2 Justin Dolske [:Dolske] 2011-12-29 17:28:58 PST
Created attachment 584890 [details]
Screenshot
Comment 3 Liz Compton [:liz] 2011-12-29 17:48:56 PST
Looks good to me.
Comment 4 Kev Needham [:kev] 2012-01-03 07:59:58 PST
Created attachment 585412 [details]
requested modification to trolololo section

I'm a little concerned about the trolololo section, and would ask that the following mod be considered. :) (I keed, I keed, but couldn't resist)

Also, hooray for this bug! \o/

(In reply to Justin Dolske [:Dolske] from comment #2)
> Created attachment 584890 [details]
> Screenshot
Comment 6 Ed Morley [:emorley] 2012-01-23 11:51:40 PST
https://hg.mozilla.org/mozilla-central/rev/b7dd715e6009
Comment 7 Justin Dolske [:Dolske] 2012-01-23 13:11:49 PST
Liz: just in case you're wondering, this change will be in Firefox 12. According to the release calendar (https://wiki.mozilla.org/RapidRelease/Calendar), that will be shipped as a stable version to all our users on 4/24 (or available as a beta on 3/13). [Well, the _actual_ ship dates are a few days later to allow to testing and such.]
Comment 8 Liz Compton [:liz] 2012-01-23 13:25:03 PST
thanks

Note You need to log in before you can comment on or make changes to this bug.