Last Comment Bug 714169 - File js/public/HashTable.h cause warning
: File js/public/HashTable.h cause warning
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Hubert Figuiere [:hub]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-29 13:18 PST by Hubert Figuiere [:hub]
Modified: 2011-12-30 04:58 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Fix warning in HashTable.h by using {} instead of ;. r= (1.04 KB, patch)
2011-12-29 13:35 PST, Hubert Figuiere [:hub]
no flags Details | Diff | Splinter Review
Fix warning in HashTable.h by using |continue;| instead of |;|. r= (1.06 KB, patch)
2011-12-29 13:36 PST, Hubert Figuiere [:hub]
jwalden+bmo: review+
Details | Diff | Splinter Review

Description Hubert Figuiere [:hub] 2011-12-29 13:18:26 PST
When building nightly, I have a lot of warnings caused by js/public/HashTable.h:204

The while(); statement.

Will attach patch to change it to while() { } as to silence the warning while remaining correct.
Comment 1 Hubert Figuiere [:hub] 2011-12-29 13:35:34 PST
Created attachment 584830 [details] [diff] [review]
Fix warning in HashTable.h by using {} instead of ;. r=
Comment 2 Hubert Figuiere [:hub] 2011-12-29 13:36:10 PST
using while() continue; as suggested by Waldo
Comment 3 Hubert Figuiere [:hub] 2011-12-29 13:36:49 PST
Created attachment 584832 [details] [diff] [review]
Fix warning in HashTable.h by using |continue;| instead of |;|. r=
Comment 4 Jeff Walden [:Waldo] (remove +bmo to email) 2011-12-29 14:27:45 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/29dc9bdea5a9
Comment 5 Kyle Huey [:khuey] (khuey@mozilla.com) 2011-12-30 04:58:14 PST
https://hg.mozilla.org/mozilla-central/rev/29dc9bdea5a9

Note You need to log in before you can comment on or make changes to this bug.