Last Comment Bug 714272 - Desktop icon on Tools/Options panel disappears if choosing to 'Save files to' Desktop
: Desktop icon on Tools/Options panel disappears if choosing to 'Save files to'...
Status: VERIFIED FIXED
[qa!]
: regression
Product: Firefox
Classification: Client Software
Component: Preferences (show other bugs)
: 10 Branch
: All All
: -- normal (vote)
: Firefox 12
Assigned To: :Gavin Sharp [email: gavin@gavinsharp.com]
:
Mentors:
Depends on:
Blocks: 474718
  Show dependency treegraph
 
Reported: 2011-12-30 06:44 PST by Paul Silaghi, QA [:pauly]
Modified: 2012-01-30 05:49 PST (History)
7 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
no desktop icon (181.77 KB, image/jpeg)
2011-12-30 06:44 PST, Paul Silaghi, QA [:pauly]
no flags Details
patch (1.26 KB, patch)
2012-01-15 15:26 PST, :Gavin Sharp [email: gavin@gavinsharp.com]
jaws: review+
Details | Diff | Review

Description Paul Silaghi, QA [:pauly] 2011-12-30 06:44:50 PST
Created attachment 584960 [details]
no desktop icon

Last good nightly: 2011-03-25
First bad nightly: 2011-03-26

Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e11c2f95f781&tochan
ge=bf68a4a3ef6a

Reproducible: always
Steps to reproduce:
1. Launch Firefox
2. Go to Tools/Options/General
3. Choose to save files to desktop and then click OK
4. Go back to Tools/Options/General

Actual results:
Desktop icon disappears.

Expected results:
Desktop icon should be displayed.

Notes:
The issue is reproducible on all platforms.
Screenshot is attached.
Comment 1 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-12-30 08:22:37 PST
Definitely a regression, though an old one.
Comment 2 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2011-12-30 08:23:05 PST
Curiously, this only seems to happen with the Desktop folder; no other folder seems to reproduce it.
Comment 3 Anthony Hughes (:ashughes) [GFX][QA][Mentor] 2012-01-05 12:32:08 PST
The fix for bug 474718 seems to be a likely culprit.
Comment 4 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-15 15:26:29 PST
Indeed, the patch for bug 474718 removed a variable ("desk") that was used later in the function... oops.
Comment 5 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-15 15:26:59 PST
Created attachment 588783 [details] [diff] [review]
patch
Comment 6 Jared Wein [:jaws] (please needinfo? me) 2012-01-15 18:08:48 PST
Comment on attachment 588783 [details] [diff] [review]
patch

Review of attachment 588783 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good. I applied this patch and tested it out too.

Unrelated to this bug, but I noticed that the dialog accepted a Library as a folder destination, but after choosing Select Folder the chosen Library didn't appear as the new download destination. It's probably because a Library is basically by-design read-only, but it's odd that it is allowed to be selected as a folder.
Comment 7 Jared Wein [:jaws] (please needinfo? me) 2012-01-16 00:21:39 PST
(In reply to Jared Wein [:jwein and :jaws] from comment #6)
> Unrelated to this bug, but I noticed that the dialog accepted a Library as a
> folder destination, but after choosing Select Folder the chosen Library
> didn't appear as the new download destination. It's probably because a
> Library is basically by-design read-only, but it's odd that it is allowed to
> be selected as a folder.

Filed bug 718374 for this.
Comment 8 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-17 15:57:59 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/8ae60977feff
Comment 10 Paul Silaghi, QA [:pauly] 2012-01-18 23:42:05 PST
The issue is reproducible on latest Nightly 12.0a1 (2012-01-18) on all platforms.
Comment 11 :Gavin Sharp [email: gavin@gavinsharp.com] 2012-01-22 13:57:28 PST
Paul: are you suggesting the fix didn't work? I can't reproduce the bug using the latest Mac Nightly, following the steps in comment 0.
Comment 12 Jared Wein [:jaws] (please needinfo? me) 2012-01-22 14:21:12 PST
(In reply to Paul Silaghi [QA] from comment #10)
> The issue is reproducible on latest Nightly 12.0a1 (2012-01-18) on all
> platforms.

The patch was merged to mozilla-central on 1-18, so the nightly build on 1-18 likely didn't include this patch.
Comment 13 Paul Silaghi, QA [:pauly] 2012-01-30 05:49:16 PST
The issue is not reproducible on:
Mozilla/5.0 (Windows NT 5.1; rv:12.0a1) Gecko/20120129 Firefox/12.0a1
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0a1) Gecko/20120129 Firefox/12.0a1
Mozilla/5.0 (X11; Linux x86_64; rv:12.0a1) Gecko/20120130 Firefox/12.0a1
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120129 Firefox/12.0a1

Setting the resolution to verified fixed.

Note You need to log in before you can comment on or make changes to this bug.