The default bug view has changed. See this FAQ.

No context menu on long tap on inputs without type=text attribute

VERIFIED FIXED in Firefox 11

Status

()

Firefox for Android
General
P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: Martijn Wargers (dead), Assigned: mbrubeck)

Tracking

11 Branch
Firefox 12
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox11 fixed, firefox12 fixed, fennec11+)

Details

(Whiteboard: [has patch], URL)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
See url, long tapping on the inputs on that page doesn't result in a context menu.
I guess because of the user-scalable=no meta tag, but I have no idea.
Assignee: nobody → wjohnston
Priority: -- → P3
Assignee: wjohnston → mbrubeck
tracking-fennec: --- → 11+
(Assignee)

Comment 1

5 years ago
Created attachment 587792 [details] [diff] [review]
patch

The selector is looking specifically for <input type="text">, so it does not match plain <input> elements.  This patch copies the code from XUL Fennec instead, which uses mozIsTextField(false).  (The "false" means "don't exclude password fields.")
Attachment #587792 - Flags: review?(wjohnston)
(Assignee)

Updated

5 years ago
Status: NEW → ASSIGNED
Whiteboard: [has patch]
(Reporter)

Updated

5 years ago
Summary: No context menu on long tap on inputs on this page (because of user-scalable: no?) → No context menu on long tap on inputs without type=text attribute
Comment on attachment 587792 [details] [diff] [review]
patch

Review of attachment 587792 [details] [diff] [review]:
-----------------------------------------------------------------

My fiendish plan to use selectors for everything is falling apart.
Attachment #587792 - Flags: review?(wjohnston) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/fa9cc1988191
status-firefox11: --- → affected
status-firefox12: --- → fixed
Target Milestone: --- → Firefox 12
Version: unspecified → Firefox 11
(Assignee)

Comment 4

5 years ago
Comment on attachment 587792 [details] [diff] [review]
patch

[Approval Request Comment]
Low-risk Android-only patch that fixes broken context menus on some form fields.  (Without the patch, it's impossible to display context menus for these elements.)
Attachment #587792 - Flags: approval-mozilla-aurora?
(Assignee)

Comment 5

5 years ago
https://hg.mozilla.org/mozilla-central/rev/fa9cc1988191
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Comment 6

5 years ago
Comment on attachment 587792 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Attachment #587792 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/98d676705242
status-firefox11: affected → fixed
Duplicate of this bug: 717095
(Reporter)

Comment 9

5 years ago
Verified fixed in today's trunk build.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.