Closed Bug 714289 Opened 8 years ago Closed 8 years ago

Only blank white pages are displayed

Categories

(Firefox for Android :: General, defect, P2)

12 Branch
All
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 11
Tracking Status
firefox11 - verified
firefox12 --- verified
firefox13 --- verified
fennec 11+ ---

People

(Reporter: fscholz, Assigned: snorp)

References

Details

(Keywords: regression)

Attachments

(1 file)

OS: Android 2.2.2 (using HTC Sense)
Device: HTC Desire 

The only page that is displayed at all is about:home.

Pages like http://mozilla.org or http://google.com will just show a blank white page without any contents (even about:config or about:addons are empty).

The URL bar is available though. It shows the loading spinner and the correct page title when finished. Scrollbars are available as well.

In current Aurora build on the same phone everything is fine.
Attached file adb logcat dump
adb logcat dump when visiting http://mozilla.de

Not sure if this is helpful. Ping me if you need more information.
I see lots of:
I/AndroidGraphicBuffer( 2758): GL error [glEGLImageTargetTexture2DOES]:            501
Duplicate of this bug: 714925
After doing a hg bisect to determine where this started, I've come up with the following revision:

http://hg.mozilla.org/mozilla-central/rev/7aa1b9862e89

This seems to be the first revision where this is happening, at least in my case.
Keywords: regression
Does the latest nightly still have a problem for you guys?
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120109 Firefox/12.0a1 Fennec/12.0a1

Still getting lots of:

I/AndroidGraphicBuffer(13439): GL error [glEGLImageTargetTexture2DOES]:    502
(In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #5)
> Does the latest nightly still have a problem for you guys?

Latest trunk isn't working for me. I'll check nightly, though.
(In reply to Scott Johnson (:jwir3) from comment #7)
> (In reply to James Willcox (:snorp) (jwillcox@mozilla.com) from comment #5)
> > Does the latest nightly still have a problem for you guys?

No, nightly isn't working for me, either.
I think this bug might have something to do with the image format in this line:

>    9.35 +static AndroidDirectTexture* sDirectTexture = new AndroidDirectTexture(2048, 2048,
>    9.36 +        AndroidGraphicBuffer::UsageSoftwareWrite | 
>                  AndroidGraphicBuffer::UsageTexture,
>    9.37 +        gfxASurface::ImageFormatRGB16_565);

Google searching on the glEGLImageTargetTexture error show this to be the case, see specifically:
http://groups.google.com/group/android-porting/browse_thread/thread/1e3383b3ea423ad9?pli=1

Definitely not 100% sure, though.
Assignee: nobody → bugmail.mozilla
tracking-fennec: --- → 11+
Priority: -- → P2
Target Milestone: --- → Firefox 11
(In reply to Scott Johnson (:jwir3) from comment #9)
> I think this bug might have something to do with the image format in this
> line:
> 
> >    9.35 +static AndroidDirectTexture* sDirectTexture = new AndroidDirectTexture(2048, 2048,
> >    9.36 +        AndroidGraphicBuffer::UsageSoftwareWrite | 
> >                  AndroidGraphicBuffer::UsageTexture,
> >    9.37 +        gfxASurface::ImageFormatRGB16_565);
> 
> Google searching on the glEGLImageTargetTexture error show this to be the
> case, see specifically:
> http://groups.google.com/group/android-porting/browse_thread/thread/
> 1e3383b3ea423ad9?pli=1
> 
> Definitely not 100% sure, though.

After testing this theory, both with my own code, and with the patch for bug 714668, I don't think this is the problem. Instead, I think the problem is that nsWindow::HasDirectTexture()
 isn't returning the correct result on some devices. If you add the following: 

  sHasDirectTexture = false;

To the top of the function nsWindow::HasDirectTexture(), the pages show up again on my device. Either that, or it could be that the GraphicsBuffer isn't being allocated corrected on the HTC devices, perhaps?
tracking-fennec: 11+ → ---
Priority: P2 → --
Target Milestone: Firefox 11 → ---
Oops, sorry, dougt, I accidentally undid some of your changes apparently.
tracking-fennec: --- → ?
Priority: -- → P2
Target Milestone: --- → Firefox 11
tracking-fennec: ? → 11+
Assignee: bugmail.mozilla → snorp
Confirming that I'm seeing this on a Dell Streak using Android 2.2.2. The initial URL I'm visiting is http://bit.ly/rpM4w5 but as per the original description all pages (google, about:addons etc.) render only white.

about:home is fine and renders thumbnails of correctly. Likewise the tab drop-down list also renders thumbnails of the content correctly.
Then that should be tracked in different bug. This bug is for all pages being white.
That's what he said I think Kevin. about:home doesn't "count". Its not an actual html page.
Fixed as part of bug 719233. We now whitelist gralloc only for known-working devices.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Nightly 13.0a1 (2012-02-13)
Aurora 12.0a2 (2012-02-13)
Beta 11.0 (2012-02-12)(20120212193918 - http://hg.mozilla.org/releases/mozilla-beta/rev/9f4a06e3fdb0)
Device: HTC Desire - Android 2.2.2

Verified fixed. No white page. Pages are correctly loaded
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.