Last Comment Bug 714315 - Use DirReaderFallback on OpenBSD, getdents64 is not defined there
: Use DirReaderFallback on OpenBSD, getdents64 is not defined there
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: IPC (show other bugs)
: Trunk
: x86 OpenBSD
: -- normal (vote)
: mozilla12
Assigned To: Landry Breuil (:gaston)
:
: [PTO to Dec5] Bill McCloskey (:billm)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-30 10:55 PST by Landry Breuil (:gaston)
Modified: 2012-01-05 07:00 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Use DirReaderFallback on OpenBSD (1.20 KB, patch)
2011-12-30 11:00 PST, Landry Breuil (:gaston)
cjones.bugs: review+
Details | Diff | Splinter Review

Description Landry Breuil (:gaston) 2011-12-30 10:55:21 PST
Followup to bug #622992, build fails in ipc with 

ipc/chromium/src/base/dir_reader_linux.h:60: error: '__NR_getdents64' was not declared in this scope

Proposed fix is to use DirReaderFallback on OpenBSD (since we are in the OS_LINUX case... bah)
Comment 1 Landry Breuil (:gaston) 2011-12-30 11:00:48 PST
Created attachment 584999 [details] [diff] [review]
Use DirReaderFallback on OpenBSD
Comment 3 :Ms2ger (⌚ UTC+1/+2) 2012-01-05 07:00:18 PST
https://hg.mozilla.org/mozilla-central/rev/18a8baa27b41

Note You need to log in before you can comment on or make changes to this bug.