Last Comment Bug 714353 - Remove nsIXPCScriptable::Trace
: Remove nsIXPCScriptable::Trace
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: XPConnect (show other bugs)
: unspecified
: All All
: -- normal (vote)
: mozilla12
Assigned To: Bill McCloskey (:billm)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-30 13:40 PST by Bill McCloskey (:billm)
Modified: 2012-01-05 08:47 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (11.47 KB, patch)
2011-12-30 13:40 PST, Bill McCloskey (:billm)
mrbkap: review+
Details | Diff | Review

Description Bill McCloskey (:billm) 2011-12-30 13:40:21 PST
Created attachment 585037 [details] [diff] [review]
patch

This method doesn't seem to be implemented by anyone in the browser. Now that we're changing the GC, it's dangerous to be implementing your own trace hooks (people are likely to forget about read and write barriers). I think we should remove this thing.
Comment 1 Blake Kaplan (:mrbkap) (please use needinfo!) 2012-01-02 03:14:00 PST
Comment on attachment 585037 [details] [diff] [review]
patch

I'm fine with this (especially since it frees up a flag on nsIXPCScriptable). I kind of wonder what this means for other API embedders who want to implement trace hooks, though. How much harder are they to write with the new GC?
Comment 2 Bill McCloskey (:billm) 2012-01-02 09:47:59 PST
(In reply to Blake Kaplan (:mrbkap) from comment #1)
> I'm fine with this (especially since it frees up a flag on
> nsIXPCScriptable). I kind of wonder what this means for other API embedders
> who want to implement trace hooks, though. How much harder are they to write
> with the new GC?

Trace hooks themselves aren't any harder to write, I guess. It's just that anything that gets traced through needs a write barrier on it. This won't really affect embedders, since they can disable all the new GC code. But I'm really interested in finding binary add-ons that implement their own trace hooks. All I know so far is that there aren't any AMO add-ons that do this.

Just as a sanity check, do you think that there are any add-ons or embedders who use nsIXPCScriptable? That would be very surprising to me.
Comment 3 Blake Kaplan (:mrbkap) (please use needinfo!) 2012-01-03 03:46:19 PST
(In reply to Bill McCloskey (:billm) from comment #2)
> Just as a sanity check, do you think that there are any add-ons or embedders
> who use nsIXPCScriptable? That would be very surprising to me.

While we haven't changed nsIXPCScriptable during a release cycle, we've generally made changes to it assuming that nobody outside of the browser uses it. The use-cases are few and far between if you're not implementing the DOM.
Comment 5 Marco Bonardo [::mak] 2012-01-05 08:47:44 PST
https://hg.mozilla.org/mozilla-central/rev/99d43af273a8

Note You need to log in before you can comment on or make changes to this bug.