Lightning not working on some Windows XP [Failed to load native module at path ...\calbasecomps.dll]

VERIFIED FIXED in 1.1.1

Status

defect
--
blocker
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: ssitter, Assigned: Fallen)

Tracking

Lightning 1.1
1.1.1
x86
Windows XP

Details

Attachments

(1 attachment)

Reporter

Description

8 years ago
I have seen several reports stating that Lightning 1.1 doesn't work. Most of the reports seem to be on Windows XP and include the following errors:

Failed to load native module at path '[...]\extensions\{e2fda1a4-762b-4020-b5ad-a41df1933103}\components\calbasecomps.dll': (80004003) error 14001

Error: Components.classes['@mozilla.org/calendar/datetime;1'] is undefined
Source: chrome://calendar/content/calUtils.js Line: 78

Firefox had a similar problem, see Bug 713167. Maybe we need a similar fix.
Posted patch Fix - v1 β€” β€” Splinter Review
Thanks for the link. This patch does what the Firefox patch does. I haven't actually tested it on windows, but it seems to compile and run on mac. Maybe you could take a look?
Assignee: nobody → philipp
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #585199 - Flags: review?(ssitter)
Comment on attachment 585199 [details] [diff] [review]
Fix - v1

>-USE_STATIC_LIBS = 1 # This links against the static CRT on Windows
> 
>+# Statically link the CRT on Windows if building against a XULrunner SDK
>+ifdef LIBXUL_SDK
>+USE_STATIC_LIBS = 1
>+endif

I don't think you need to do this as you're always going to be a shared library, so I'd say no to this change.

>+# Ensure that we don't embed a manifest referencing the CRT
>+EMBED_MANIFEST_AT =

This needs to come after rules.mk is included.
Attachment #585199 - Flags: review?(ssitter) → review-
As discussed on IRC, just the EMBED_MANIFEST_AT line, put at the end of the file. pushing in a minute.
Pushed to comm-central changeset e139a77f8bb1
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → 1.4
Backported to releases/comm-aurora changeset bfc2a749cd70
Target Milestone: 1.4 → 1.3
Backported to releases/comm-beta changeset 318f73969038
Target Milestone: 1.3 → 1.2
Backported to releases/comm-release changeset d6f17beb0a32 for Lightning 1.1.1
Target Milestone: 1.2 → 1.1.1
I just verified this works for trunk builds on my Windows XP without MSVC redist files.
Status: RESOLVED → VERIFIED
Reporter

Comment 9

8 years ago
When trying to reproduce / verify this problem I noticed that vanilla Thunderbird has a similar problem. Thunderbird would not startup at all on my Windows XP system until after I installed the Microsoft Visual C++ 2005 Service Pack 1 Redistributable Package.
(In reply to Stefan Sitter from comment #9)
> When trying to reproduce / verify this problem I noticed that vanilla
> Thunderbird has a similar problem. Thunderbird would not startup at all on
> my Windows XP system until after I installed the Microsoft Visual C++ 2005
> Service Pack 1 Redistributable Package.

As always, please specify your version. Problematic versions of Thunderbird would be 9.0 and 10.0b1. All other current branch versions should be fixed, if not please file a bug.
Reporter

Updated

8 years ago
Duplicate of this bug: 713425
You need to log in before you can comment on or make changes to this bug.