Last Comment Bug 714495 - Port Bug 713167 - |Microsoft.VC80.CRT SideBySide errors, browsercomps.dll| to comm
: Port Bug 713167 - |Microsoft.VC80.CRT SideBySide errors, browsercomps.dll| to...
Status: RESOLVED FIXED
: regression
Product: MailNews Core
Classification: Components
Component: Build Config (show other bugs)
: 12
: x86 All
: -- major (vote)
: Thunderbird 12.0
Assigned To: Justin Wood (:Callek)
:
:
Mentors:
Depends on: 713167
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-31 22:04 PST by Justin Wood (:Callek)
Modified: 2012-01-21 05:34 PST (History)
19 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed
fixed


Attachments
v1 (842 bytes, patch)
2011-12-31 22:16 PST, Justin Wood (:Callek)
standard8: review-
Details | Diff | Splinter Review
v2 (1019 bytes, patch)
2012-01-06 20:47 PST, Justin Wood (:Callek)
standard8: review+
standard8: approval‑comm‑aurora+
Details | Diff | Splinter Review

Description Justin Wood (:Callek) 2011-12-31 22:04:47 PST
+++ This bug was initially created as a clone of Bug #713167 +++

User Agent: Mozilla/5.0 (Windows NT 5.1; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

Removed all .NET Framework and VC++ 2005 SP1 redistributable from Windows XP SP3.


Actual results:

Loading browsercomps.dll fails due to SideBySide error. This causes the problems such as the following:
* RSS feed function did not work correctly. For exanple: http://samlab.ws/rss/
* Decreased the number of items of "about:about".


Expected results:

Should load browsercomps.dll correctly.
Comment 1 Justin Wood (:Callek) 2011-12-31 22:16:14 PST
Created attachment 585179 [details] [diff] [review]
v1

Requesting approval. This does just like the dep Firefox bug to fix a real issue on XP.
Comment 2 Mark Banner (:standard8) 2012-01-03 03:11:43 PST
Comment on attachment 585179 [details] [diff] [review]
v1

Thunderbird doesn't actually need this, as the mailcomps module is built into libxul.

I'm not quite sure what to do, but I'm leaning towards making it a comment near the top of the file that if we switch away from LIBXUL_LIBRARY at any stage, we need to clear the EMBED_MANIFEST_AT flag.
Comment 3 Mark Banner (:standard8) 2012-01-05 13:16:02 PST
Comment on attachment 585179 [details] [diff] [review]
v1

Cancelling requests pending new patch.
Comment 4 Justin Wood (:Callek) 2012-01-06 20:47:21 PST
Created attachment 586638 [details] [diff] [review]
v2
Comment 5 Mark Banner (:standard8) 2012-01-11 02:02:52 PST
Comment on attachment 586638 [details] [diff] [review]
v2

That's better, thanks.

Note You need to log in before you can comment on or make changes to this bug.