Closed Bug 714657 Opened 11 years ago Closed 10 years ago

Blow away stored prefs during setup

Categories

(Firefox for Android Graveyard :: Android Sync, defect, P1)

defect

Tracking

(fennec+)

VERIFIED FIXED
mozilla16
Tracking Status
fennec + ---

People

(Reporter: rnewman, Assigned: nalexander)

References

()

Details

Uninstallation/reinstallation of Fennec will often cause your Sync account to disappear. Alas, that doesn't cause your prefs to be wiped, and so your last sync timestamps persist.

We should wipe the whole pref tree prior to writing at the end of setup.
In fact, we can probably do this in our equivalent of resetClient, which we should do on a first sync. Need to implement first sync logic, of course :)
tracking-fennec: --- → ?
tracking-fennec: ? → +
This has an impact on testing, so setting a priority.
Assignee: rnewman → nobody
Status: ASSIGNED → NEW
Priority: -- → P2
Priority: P2 → P1
Duplicate of this bug: 718130
Assignee: nobody → nalexander
To verify this happens before fix is applied:

1. pair device with desktop
2. force sync
3. delete Android account
4. (quickly) pair device a second time with same Sync account
5. verify first sync after pairing does not happen and a log entry like the following is present:

I SyncAdapter(22616)          Not syncing: must wait another 232943ms.

To verify this has been fixed:

Repeat steps 1. through 4.  On step 5., you should see a full sync happen, and you should have log entries like the following present:

W GlobalSession(24855)        Remote syncID different from local syncID: resetting client and assuming remote syncID.
Status: NEW → ASSIGNED
With the latest inbound build (20120612), I am still seeing :
Not syncing: must wait another xxx ms.
right after pairing device a second time with the same sync account.
(In reply to Xiao Meng Wei :xwei from comment #6)
> With the latest inbound build (20120612), I am still seeing :
> Not syncing: must wait another xxx ms.
> right after pairing device a second time with the same sync account.

My guess is we need to wait to get the right build.  Can we leave this until tomorrow's nightly?
https://hg.mozilla.org/mozilla-central/rev/6bbc085e39b5
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Following the steps from comment 4, all works as expected. 

Verified fixed on 
- build: Firefox 16.0a1 (2012-06-14)
- device: Samsung Galaxy SII 
- SO: Android 2.3.4
Status: RESOLVED → VERIFIED
Product: Mozilla Services → Android Background Services
Product: Android Background Services → Firefox for Android
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.