Last Comment Bug 714676 - IonMonkey: Frame descriptors are not always correct
: IonMonkey: Frame descriptors are not always correct
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: ---
Assigned To: David Anderson [:dvander]
:
Mentors:
Depends on:
Blocks: 677337
  Show dependency treegraph
 
Reported: 2012-01-02 14:07 PST by David Anderson [:dvander]
Modified: 2012-01-04 10:53 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (3.90 KB, patch)
2012-01-02 14:32 PST, David Anderson [:dvander]
jdemooij: review+
Details | Diff | Splinter Review

Description David Anderson [:dvander] 2012-01-02 14:07:33 PST
A few tests are failing because frame descriptors are not correct.
Comment 1 David Anderson [:dvander] 2012-01-02 14:32:29 PST
Created attachment 585334 [details] [diff] [review]
fix

Two bugs here: one is that CallGeneric was not including the right frame size in its outgoing descriptor (the size must be the distance between the two frame headers), and EnsureExitFrame could overwrite the previous frame type.
Comment 2 David Anderson [:dvander] 2012-01-03 11:44:28 PST
http://hg.mozilla.org/projects/ionmonkey/rev/8c20b26f0209

Note You need to log in before you can comment on or make changes to this bug.