The default bug view has changed. See this FAQ.

IonMonkey: Unbox OSR Values.

RESOLVED FIXED

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: nbp, Assigned: nbp)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
OSR entry point are currently generating MIRType_Value.  The problem is that OSR will be merged with other entry points for which we may have specialized the type.  Phi nodes of the loop header are then discarding the most specialized value and keep the MIRType_Value instead.  Thus the loop will have to unbox/box at each loop iteration.

We cannot rely on the ArgTypes and ThisTypes because they refer to the function entry and not to the loop header.

MethodJIT stores a vector of type for arg/local slots (naming ActiveFrame::varTypes), one similar solution for IonMonkey would be to re-use the slots types of any other entry point (MBasicBlock) of the loop, to produce fallible unboxing for OSR entry point.
(Assignee)

Updated

5 years ago
Assignee: general → nicolas.b.pierron
Status: NEW → ASSIGNED
(Assignee)

Comment 1

5 years ago
Created attachment 586749 [details] [diff] [review]
Unbox OSR Value before preheader

Copy types from the main-line as fallible assumptions for OSR entry-points.
Attachment #586749 - Flags: review?(sstangl)
Attachment #586749 - Flags: review?(bhackett1024)
Attachment #586749 - Flags: review?(bhackett1024) → review+
Comment on attachment 586749 [details] [diff] [review]
Unbox OSR Value before preheader

Review of attachment 586749 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good.
Attachment #586749 - Flags: review?(sstangl) → review+
(Assignee)

Comment 3

5 years ago
https://hg.mozilla.org/projects/ionmonkey/rev/fedf408a1cf3
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.