Leak of 18 bytes in malloc_zone_malloc as detected by Valgrind on Mac OS X Lion

RESOLVED WONTFIX

Status

()

--
critical
RESOLVED WONTFIX
7 years ago
7 years ago

People

(Reporter: gkw, Unassigned)

Tracking

(Blocks: 1 bug, {testcase, valgrind})

Trunk
x86
Mac OS X
testcase, valgrind
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: js-triage-needed)

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
Created attachment 585340 [details]
stack

quit()

shows the attached leak signature on 32-bit debug js shell on m-c changeset d77b056ed4bd on Mac OS X Lion.

CLI command: valgrind --dsymutil=yes --leak-check=full ./js

Using Valgrind SVN rev 12325:

Last Changed Author: florian
Last Changed Rev: 12325
Last Changed Date: 2012-01-02 08:12:30 -0800 (Mon, 02 Jan 2012)

Configured using:

sh ./configure --target=i386-apple-darwin8.0.0 --enable-optimize --disable-debug --enable-profiling --enable-valgrind --disable-tests --enable-type-inference --enable-more-deterministic
(Reporter)

Comment 1

7 years ago
Just to confirm, the error also shows with js opt shells.
Well, that seems like a leak in the system libraries, no?  I bet you
can't repro this on Linux.
(Reporter)

Comment 3

7 years ago
Filed in ADC id 10652055. Will the lack of Spidermonkey lines be a clue in deciding that this is a problem with the system libraries?
Uh, as per comment #2, did you check whether you can repro this leak on Linux?
It won't reproduce on Linux, because Linux doesn't have malloc_zone_malloc and the libraries are all Mac-specific.  A deeper stack-trace (via --num-callers=50) might be instructive.
(Reporter)

Comment 6

7 years ago
Created attachment 586372 [details]
Valgrind stack w/ --num-callers=50
(Reporter)

Comment 7

7 years ago
> Uh, as per comment #2, did you check whether you can repro this leak on
> Linux?

Yes, I did, it does not reproduce on 64-bit opt shell w/ Valgrind.
(Reporter)

Comment 8

7 years ago
> Yes, I did, it does not reproduce on 64-bit opt shell w/ Valgrind.

*does not reproduce on Linux*
I thought I commented on this... maybe the comment was eaten, or maybe I commented in another similar bug.  Anyway, that stack trace is all Mac system library stuff beyond our control.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.