Closed Bug 714920 Opened 8 years ago Closed 8 years ago

Context menu for an empty input field should not include "Copy All" or "Select All"

Categories

(Firefox for Android :: General, defect, P4)

ARM
Android
defect

Tracking

()

VERIFIED FIXED
Firefox 12
Tracking Status
firefox11 --- verified
firefox12 --- verified
fennec 11+ ---

People

(Reporter: aaronmt, Assigned: mbrubeck)

References

()

Details

(Whiteboard: [has patch])

Attachments

(1 file)

Long tapping on an empty input field presents the context menu with the options: "Copy All", "Select All", and "Select Input Method". Of those, only the third option would be of interest in this situation. Rather than invoking the context menu on an empty field, a long tap should be just interpreted as an attempt to focus the field.

STR: http://mail.yahoo.com, long tap into the empty 'Yahoo! ID' or 'Password' field.
Assignee: nobody → wjohnston
Priority: -- → P4
Assignee: wjohnston → mbrubeck
I'm not sure about this.  "Paste" and "Select Input Method" are both valid for empty input fields.  If you want to focus the input field, why not just single-tap on it?

We should definitely eliminate "Copy All" and "Select All" when the field is empty.
Removing [parity-stock] because the stock browser does display a context menu for empty input fields, at least in my HTC T-Mobile G2 (stock Android 2.3).
Whiteboard: [parity-stock]
Let's just fixup the context menu entries for an empty textbox. Adjust bug summary as needed.
Status: NEW → ASSIGNED
Summary: Long tap on an empty input field should focus it rather than invoke context menu → Context menu for an empty input field should not include "Copy All" or "Select All"
Whiteboard: [has patch]
Attached patch patchSplinter Review
This hides the "Copy All" and "Select All" when there is nothing to copy or select.

This also steals a line from XUL fennec to hide "Copy" and "Copy All" for password fields.
Attachment #587800 - Flags: review?(mark.finkle)
tracking-fennec: --- → 11+
Attachment #587800 - Flags: review?(mark.finkle) → review+
Comment on attachment 587800 [details] [diff] [review]
patch

[Approval Request Comment]
This is a low-risk Android-only patch that fixes several cases where the wrong context menu items appear for form fields.
Attachment #587800 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/f383c28a6dfa
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Verified on 
Nightly 12.0a1 (2012-01-16) "Select Input Method" and "Paste" options are displayed.

Still reproducible on Aurora 11.0a2 (2012-01-15).
Status: RESOLVED → VERIFIED
Comment on attachment 587800 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approved for Aurora.
Attachment #587800 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified on Aurora 11.0a2 (2012-01-17)
Only "Select Input Method" and "Paste" options are displayed for empty fields.
You need to log in before you can comment on or make changes to this bug.