clean up nsIGlobalHistory

VERIFIED FIXED in mozilla0.9

Status

defect
P3
normal
VERIFIED FIXED
19 years ago
11 months ago

People

(Reporter: jud, Assigned: alecf)

Tracking

Trunk
mozilla0.9
x86
Linux
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: fix in hand, )

Attachments

(1 attachment)

Reporter

Description

19 years ago
It's an implementation detail that should not live in a public iface.
Reporter

Updated

19 years ago
Blocks: 70229
Assignee

Comment 1

19 years ago
Can't I just make this a dupe of 71482? :)
Status: NEW → ASSIGNED
Depends on: 71482
Priority: -- → P3
Target Milestone: --- → mozilla0.9
Assignee

Comment 2

19 years ago
eh, screw it. I have an API fix that I'm going to roll into this.
Summary: nsIGlobalHistory should remove addTitle() method. → clean up nsIGlobalHistory
Assignee

Comment 4

19 years ago
I'll clean up the comment for isVisited()

I removed the whole referrer thing because nobody seems to actually use it (yet)
at some point we'll probably set that information at the same time we set the 
page title, so for now I'll leave it alone in the database.
Assignee

Updated

19 years ago
Whiteboard: fix in hand
Reporter

Comment 5

19 years ago
nice! r=valeski.
Reporter

Comment 6

19 years ago
actually, r=valeski after a comment on IsVisited(). Maybe point it back to
AddPage() w/ something like.

IsVisited() returns TRUE if a page had been passed into AddPage(). If the string
passed into IsVisited was never passed into AddPage(), return FALSE.
Reporter

Updated

19 years ago
Blocks: 64833
Assignee

Comment 8

19 years ago
oops, I forgot that checked this in.
Status: ASSIGNED → RESOLVED
Closed: 19 years ago
Resolution: --- → FIXED
Reporter

Updated

19 years ago
No longer depends on: 71482

Updated

18 years ago
No longer blocks: 64833
mass-verifying claudius' Fixed bugs which haven't changed since 2001.12.31.

if you think this particular bug is not fixed, please make sure of the following
before reopening:

a. retest with a *recent* trunk build.
b. query bugzilla to see if there's an existing, open bug (new, reopened,
assigned) that covers your issue.
c. if this does need to be reopened, make sure there are specific steps to
reproduce (unless already provided and up-to-date).

thanks!

[set your search string in mail to "AmbassadorKoshNaranek" to filter out these
messages.]
Status: RESOLVED → VERIFIED

Updated

11 months ago
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.