Last Comment Bug 715204 - Non-ascii titles are displayed as garbage during session restore
: Non-ascii titles are displayed as garbage during session restore
Status: VERIFIED FIXED
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: Firefox 12
Assigned To: Makoto Kato [:m_kato] (PTO 6/20-21, 6/24)
:
Mentors:
http://ja.m.wikipedia.org/wiki/%E3%83...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-04 10:35 PST by Mike Hommey [:glandium]
Modified: 2013-02-28 03:30 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
+
fixed
11+


Attachments
Title as mojibake (25.87 KB, image/png)
2012-01-04 10:35 PST, Mike Hommey [:glandium]
no flags Details
Title in japanese (186.38 KB, image/png)
2012-01-04 10:36 PST, Mike Hommey [:glandium]
no flags Details
fix (2.20 KB, patch)
2012-01-18 00:04 PST, Makoto Kato [:m_kato] (PTO 6/20-21, 6/24)
bnicholson: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Review

Description Mike Hommey [:glandium] 2012-01-04 10:35:50 PST
Created attachment 585808 [details]
Title as mojibake

STR:
- Go to http://ja.m.wikipedia.org/wiki/%E3%83%9E%E3%83%89%E3%83%AC%E3%83%BC%E3%83%8C%E5%AF%BA%E9%99%A2
- Start other applications such that Nightly is OOM killed
- Start Nightly.

What happens:
- Title is shown in japanese.
- Title is then shown as mojibake.
- Title is shown in japanese again.

I'll be attaching screenshots for 2 and 3.
Comment 1 Mike Hommey [:glandium] 2012-01-04 10:36:23 PST
Created attachment 585810 [details]
Title in japanese
Comment 2 Makoto Kato [:m_kato] (PTO 6/20-21, 6/24) 2012-01-18 00:04:51 PST
Created attachment 589418 [details] [diff] [review]
fix

readInputStreamToString handles us-ascii.  We should use 3rd option to read as UTF-8.
Comment 3 Brian Nicholson (:bnicholson) 2012-01-18 11:13:34 PST
Comment on attachment 589418 [details] [diff] [review]
fix

Looks fine to me.
Comment 4 Makoto Kato [:m_kato] (PTO 6/20-21, 6/24) 2012-01-19 03:37:24 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/1fd3d6234686
Comment 5 Matt Brubeck (:mbrubeck) 2012-01-19 11:00:11 PST
https://hg.mozilla.org/mozilla-central/rev/1fd3d6234686
Comment 6 Brad Lassey [:blassey] (use needinfo?) 2012-01-20 12:42:39 PST
Comment on attachment 589418 [details] [diff] [review]
fix

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
Unicode chars not rendered correctly
Testing completed (on m-c, etc.): 
Risk to taking this patch (and alternatives if risky):
very low, just specifies the encoding
Comment 7 Alex Keybl [:akeybl] 2012-01-20 12:59:59 PST
Comment on attachment 589418 [details] [diff] [review]
fix

[Triage Comment]
Mobile only - approved for Aurora.
Comment 8 Brad Lassey [:blassey] (use needinfo?) 2012-01-20 13:45:23 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/ba758404a5ad
Comment 9 Andreea Pod 2013-02-28 03:30:33 PST
Verified fixed on:
-build: Firefox for Android 22.0a1 (2013-02-27)
-device: Samsung Galaxy Nexus
-OS: Android 4.2.2

Note You need to log in before you can comment on or make changes to this bug.