Last Comment Bug 715260 - Remove Web Apps shortcut intent from allowing one to add the Android widget
: Remove Web Apps shortcut intent from allowing one to add the Android widget
Status: RESOLVED FIXED
[inbound]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: Trunk
: ARM Android
: P2 normal (vote)
: Firefox 13
Assigned To: Sriram Ramasubramanian [:sriram]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-04 12:02 PST by Aaron Train [:aaronmt]
Modified: 2012-02-06 13:12 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed
fixed
11+


Attachments
Patch (1.65 KB, patch)
2012-01-31 15:33 PST, Sriram Ramasubramanian [:sriram]
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
akeybl: approval‑mozilla‑beta+
Details | Diff | Review

Description Aaron Train [:aaronmt] 2012-01-04 12:02:29 PST
As far as I know you can't install Web Apps in Nightly/Aurora, but you can add the $BRAND Web Apps widget to ones home-screen. Until the support is added, this should probably be hidden or removed.
Comment 1 Aaron Train [:aaronmt] 2012-01-04 12:03:14 PST
(When you attempt to add the widget you'll get a message, "No Web Apps Found")
Comment 2 Aaron Train [:aaronmt] 2012-01-20 12:47:55 PST
@wesj, I guess just <activity android:name="LauncherShortcuts"></activity>
Comment 3 Sriram Ramasubramanian [:sriram] 2012-01-31 14:55:00 PST
Does this need "removal" of all corresponding code? Or just "hiding" the "Fennec Web Apps" in android widget section?
Comment 4 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-31 15:00:24 PST
Fabrice - Does the future of WebApps use the same kind of code as we currently have? If not we could remove it all. If it will be similar, we could just remove the minimum needed to hide the widget.
Comment 5 [:fabrice] Fabrice Desré 2012-01-31 15:05:13 PST
Yes, there will be the same kind of API available from js. Hiding the widget looks like a good solution for now.
Comment 6 Mark Finkle (:mfinkle) (use needinfo?) 2012-01-31 15:05:49 PST
(In reply to Fabrice Desré [:fabrice] from comment #5)
> Yes, there will be the same kind of API available from js. Hiding the widget
> looks like a good solution for now.

Sriram - Sounds like a plan
Comment 7 Sriram Ramasubramanian [:sriram] 2012-01-31 15:33:25 PST
Created attachment 593245 [details] [diff] [review]
Patch

Hiding the Activity in AndroidManifest so that this can be re-used later when supported.
Comment 8 Sriram Ramasubramanian [:sriram] 2012-02-01 11:44:17 PST
http://hg.mozilla.org/integration/mozilla-inbound/rev/55f7963473f3
Comment 9 Ed Morley [:emorley] 2012-02-02 07:22:37 PST
https://hg.mozilla.org/mozilla-central/rev/55f7963473f3
Comment 10 Sriram Ramasubramanian [:sriram] 2012-02-02 09:59:27 PST
Comment on attachment 593245 [details] [diff] [review]
Patch

[Approval Request Comment]
User impact if declined: 
User will see a Fennec widget in "Widgets" section of the device. However he will not be able to add any.

Testing completed (on m-c, etc.): Landed on m-c on 02/01

Risk to taking this patch (and alternatives if risky):
None. This just hides exposing the widget.

String changes made by this patch:
None.
Comment 11 Alex Keybl [:akeybl] 2012-02-05 13:37:55 PST
Comment on attachment 593245 [details] [diff] [review]
Patch

[Triage Comment]
Mobile only - approved for Aurora 12 and Beta 11.
Comment 12 Mark Finkle (:mfinkle) (use needinfo?) 2012-02-06 09:25:21 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/f010ed04ac8d
Comment 13 Sriram Ramasubramanian [:sriram] 2012-02-06 13:09:56 PST
https://hg.mozilla.org/releases/mozilla-beta/rev/841c659c14d8

Note You need to log in before you can comment on or make changes to this bug.