Style does not effect the text in TD if it was set as a TR attribute

VERIFIED DUPLICATE of bug 46480

Status

()

VERIFIED DUPLICATE of bug 46480
18 years ago
17 years ago

People

(Reporter: vladimire, Assigned: pierre)

Tracking

Trunk
mozilla1.0
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
In a table if you want to have a style affecting the whole row, you have to 
specify it for every cell. Setting style attribute of TR doesnt effect the cels.
Ex.
<TABLE>
<TR style="red">
<TD>Text</TD>
</TR>
</TABLE>

Text is not red. In IE it is red.
(Reporter)

Comment 1

18 years ago
Created attachment 27332 [details]
testcase
(Reporter)

Updated

18 years ago
OS: Windows 98 → All
Table layout problem, over to karnaze.
Assignee: jst → karnaze
Component: DOM Style → HTMLTables

Comment 3

18 years ago
Reassigning to Pierre and marking m1.0.
Assignee: karnaze → pierre
Target Milestone: --- → mozilla1.0
Created attachment 34727 [details]
second test case
The second test case I added shows that the bug does not occur if the DOCTYPE
is declared....

Comment 6

18 years ago
The behavior is correct in Standard mode, wrong in Quirks mode. Tables are very
bad in Quirks mode. I think that the inheritance of the color is explicitly cut
off, by design, to be Nav. compatable.

I think that tis is WONTFIX. There are other bug arguing the merits of the table
quirks code, since IE and Nav differ on those quirks and IE is more promiment
nowadays.
Not my area. QA -> amar.
QA Contact: ian → amar

Comment 8

17 years ago

*** This bug has been marked as a duplicate of 46480 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Hardware: PC → All
Resolution: --- → DUPLICATE

Comment 9

17 years ago
 The bug was fixed.. The text is shown in red color.. Marking verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.