Last Comment Bug 715396 - [Mac] Netflix not playing videos with some hardware
: [Mac] Netflix not playing videos with some hardware
Status: RESOLVED WORKSFORME
:
Product: Firefox
Classification: Client Software
Component: General (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal with 1 vote (vote)
: ---
Assigned To: Steven Michaud [:smichaud] (Retired)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-04 17:11 PST by Jody Orrison
Modified: 2015-10-07 18:36 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+


Attachments
sample of ff plugin process for silverligh (65.74 KB, text/plain)
2012-01-10 22:27 PST, Naoki Hirata :nhirata (please use needinfo instead of cc)
no flags Details
Sample of Firefox process (200.30 KB, text/plain)
2012-01-10 22:27 PST, Naoki Hirata :nhirata (please use needinfo instead of cc)
no flags Details
Screenshot of Netflix in Firefox 9.0 64-bit (143.21 KB, image/png)
2012-01-12 11:38 PST, Marcia Knous [:marcia - use ni]
no flags Details

Description Jody Orrison 2012-01-04 17:11:00 PST
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Build ID: 20111220165912

Steps to reproduce:

updated firefox


Actual results:

netflix will not play


Expected results:

should have gone the bookmark link and play - bookmark name and password were remembered, now are not and play goes to black screen.
Comment 1 Marcia Knous [:marcia - use ni] 2012-01-10 14:41:19 PST
Hello Jody - which version of Silverlight you are using? You can type about:plugins in the URL bar to get the version number. Thanks.
Comment 2 Alex Keybl [:akeybl] 2012-01-10 14:43:26 PST
We've seen more reports in https://support.mozilla.org/en-US/questions/906338
Comment 3 Jody Orrison 2012-01-10 15:03:22 PST
Hi, I don't know what silverlight is. I just updated my firefox and now netflix won't play...

J~
Comment 4 Marcia Knous [:marcia - use ni] 2012-01-10 17:21:44 PST
I have been able to reproduce this issue so far on only one 10.6 machine in the QA lab. It does not reproduce on my 10.6 laptop with the same Silverlight version/9.0.1. Machine specs on the machine where it reproduces:

Graphics
      
Adapter Description0x22600,0x20400
WebGL RendererNVIDIA Corporation -- NVIDIA GeForce 9400 OpenGL Engine -- 2.1 NVIDIA-1.6.36
GPU Accelerated Windows1/1 OpenGL

Netflix video black screen: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

Netflix videos play fine using:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101 Firefox/10.0
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0a1) Gecko/20120110 Firefox/12.0a1

I also tested Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:9.0.1) Gecko/20100101 Firefox/9.0.1 on a different machine and videos play fine there.

Testing using Silverlight Version: 5.0.61118.0 which is the same version that one user reported in the SUMO forum. Need to drill down to see if this is confined only to that version. Will test on 10.7 as well as another 10.6 machine.
Comment 5 Marcia Knous [:marcia - use ni] 2012-01-10 17:50:50 PST
Testing on a different 10.6 machine, iMac.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1 - Netflix Videos play fine using Silverlight Version: 4.0.60831.0

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1 - Netflix Black Screen on Version: 5.0.61118.0

STR:
1. Load netflix.com with Silverlight Version: 4.0.60831.0
2. Play and video and confirm it plays.
3. Go to Silverlight site and download Silverlight 5.
4. After installing Silverlight, confirm that you have Silverlight 5 by going to about:plugins.
5. Try to play a video at netflix.com
6. See a black screen instead of video content. Happens with bing videos as well.

Juan mentioned that he cannot reproduce this is on his new Macbook Air.
Comment 6 Marcia Knous [:marcia - use ni] 2012-01-10 18:23:40 PST
Testing on 10.7.2 machine in the lab, I am not able to reproduce the problem using 9.0.1 and Silverlight 5. Videos play fine with both versions of Silverlight on that machine. This machine is a Mac mini.
Comment 7 Jody Orrison 2012-01-10 18:55:21 PST
(In reply to Marcia Knous [:marcia] from comment #1)
> Hello Jody - which version of Silverlight you are using? You can type
> about:plugins in the URL bar to get the version number. Thanks.

Silverlight Plug-In

    File: Silverlight.plugin
    Version: 5.0.61118.0
    5.0.61118.0
Comment 8 Jody Orrison 2012-01-10 18:57:15 PST
(In reply to Marcia Knous [:marcia] from comment #4)
> I have been able to reproduce this issue so far on only one 10.6 machine in
> the QA lab. It does not reproduce on my 10.6 laptop with the same
> Silverlight version/9.0.1. Machine specs on the machine where it reproduces:
> 
> Graphics
>       
> Adapter Description0x22600,0x20400
> WebGL RendererNVIDIA Corporation -- NVIDIA GeForce 9400 OpenGL Engine -- 2.1
> NVIDIA-1.6.36
> GPU Accelerated Windows1/1 OpenGL
> 
> Netflix video black screen: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6;
> rv:9.0.1) Gecko/20100101 Firefox/9.0.1
> 
> Netflix videos play fine using:
> 
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:10.0) Gecko/20100101
> Firefox/10.0
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:12.0a1) Gecko/20120110
> Firefox/12.0a1
> 
> I also tested Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:9.0.1)
> Gecko/20100101 Firefox/9.0.1 on a different machine and videos play fine
> there.
> 
> Testing using Silverlight Version: 5.0.61118.0 which is the same version
> that one user reported in the SUMO forum. Need to drill down to see if this
> is confined only to that version. Will test on 10.7 as well as another 10.6
> machine.

I have an imac about a year and a half old running Mac OS X 10.6.8
Comment 9 Jody Orrison 2012-01-10 18:58:24 PST
(In reply to Marcia Knous [:marcia] from comment #5)
> Testing on a different 10.6 machine, iMac.
> 
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101
> Firefox/9.0.1 - Netflix Videos play fine using Silverlight Version:
> 4.0.60831.0
> 
> Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101
> Firefox/9.0.1 - Netflix Black Screen on Version: 5.0.61118.0
> 
> STR:
> 1. Load netflix.com with Silverlight Version: 4.0.60831.0
> 2. Play and video and confirm it plays.
> 3. Go to Silverlight site and download Silverlight 5.
> 4. After installing Silverlight, confirm that you have Silverlight 5 by
> going to about:plugins.
> 5. Try to play a video at netflix.com
> 6. See a black screen instead of video content. Happens with bing videos as
> well.
> 
> Juan mentioned that he cannot reproduce this is on his new Macbook Air.

How would I change this Silverlight plugin from 5.0 to 4.0?

J~
Comment 10 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-10 22:27:03 PST
Created attachment 587596 [details]
sample of ff plugin process for silverligh

Also occurred for me on a 2.4 Ghz Intel Core 2 Duo MacBook running 10.6.8; GeForce 8600M GT.  Did not occur while running 10.7 on a 2.0 Ghz Intel Core 2 Duo Mac Mini.

Commonality seems to be an Intel Core 2 Duo running on 10.6.8 so far.
Comment 11 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-10 22:27:42 PST
Created attachment 587597 [details]
Sample of Firefox process
Comment 12 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-10 22:59:10 PST
Black screen occurred on 9.0 as well as 9.0b6

Black screen did not occur using 10.0b3
Comment 13 Jody Orrison 2012-01-11 07:27:36 PST
(In reply to Naoki Hirata :nhirata from comment #12)
> Black screen occurred on 9.0 as well as 9.0b6
> 
> Black screen did not occur using 10.0b3

I have an intel core i3....Silverlight 5.0
Comment 14 Marcia Knous [:marcia - use ni] 2012-01-11 10:45:05 PST
One tester reports:

The plugin container process is returning an error to the system console, only when it fails:
"unknown error code: invalid display"
Comment 15 Steven Michaud [:smichaud] (Retired) 2012-01-11 12:32:30 PST
Marcia, Naoki:

Could one of you try to find a regression range in mozilla-central nightlies?

And perhaps also a "degression" range, if the problem no longer exists with current trunk code?

Note that Silverlight pays attention to the user agent string, and (because of this) has in the past misidentified mozilla-central nightlies as not being Firefox.  So you should set your user-agent string to that of a Firefox release for at least some of your tests on mozilla-central nightlies (and perhaps also other kinds of nightlies).

More in my next comment about how to set the user-agent string.
Comment 16 Steven Michaud [:smichaud] (Retired) 2012-01-11 12:45:32 PST
Here's how to make any version of Firefox (including mozilla-central
nightlies) use FF 9.0.1's user-agent string:

1) Run FF 9.0.1 and visit http://browserspy.dk/browser.php and copy
   the "navigator.userAgent" string (up to but not including the final
   '.' character).

   On OS X 10.6.8 this is:

   Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1

2) Quit FF 9.0.1 and run the version of Firefox you wish to test with.

3) Enter "about:config" in the location bar and click the "I'll be
   careful" button.

4) Right-click (or ctrl-click) on the settings panel and choose New :
   String.

5) Enter "general.useragent.override" as the "preference name".

6) Enter the string you copied in step 1 as the "string value".

7) You need to restart Firefox to make this change take effect.
Comment 17 Steven Michaud [:smichaud] (Retired) 2012-01-11 12:47:22 PST
Here's FF 9.0.1's user-agent string over again, hopefully this time without a line break in it:

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1
Comment 18 Alex Keybl [:akeybl] 2012-01-11 16:12:53 PST
Found another report of this here: http://forums.silverlight.net/t/246879.aspx/1
Comment 19 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-11 16:19:55 PST
Seems like it would be a lot easier just to use User Agent Switcher addon : https://addons.mozilla.org/en-US/firefox/addon/user-agent-switcher/ and change the user-agent string that way.  Would that be ok, Steven?
Comment 20 Marcia Knous [:marcia - use ni] 2012-01-11 17:05:15 PST
When testing, I also see this in the error console:

Error: junk after document element
Source File: http://movies.netflix.com/proxy-us/nccp/controller/2.11/logblob
Line: 2, Column: 1
Source Code:
<?xml version="1.0" encoding="utf-8"?><nccp:response xmlns:nccp="http://www.netflix.com/eds/nccp/2.11">
Comment 21 Steven Michaud [:smichaud] (Retired) 2012-01-11 17:12:23 PST
(In reply to comment #19)

> Would that be ok, Steven?

Sure.  Any way that works to set the user-agent string is just fine.

But however we do it, it's really important to test nightlies with a release user-agent string.  It may turn out that this bug *isn't* fixed in current code.
Comment 22 Steven Michaud [:smichaud] (Retired) 2012-01-11 17:16:00 PST
> But however we do it, it's really important to test nightlies with a
> release user-agent string.  It may turn out that this bug *isn't*
> fixed in current code.

It's really important to test this way with both nightlies and
"pre-releases" (e.g. alphas and betas).
Comment 23 Marcia Knous [:marcia - use ni] 2012-01-11 17:27:09 PST
And in the Mac Console App I get this error, not sure if it is useful. 

1/11/12 5:03:27 PM	Silverlight Preferences[3623]	Could not connect the action SetGPUVideoDecodeEnabled: to target of class PrefsPaneController

Now back to our regularly scheduled regression hunting.
Comment 24 Marcia Knous [:marcia - use ni] 2012-01-11 17:39:26 PST
From what I can see, Netflix works in the current trunk nightly when I change the UA to 9.0.1. It also works without changing it as well.
Comment 25 Steven Michaud [:smichaud] (Retired) 2012-01-11 18:02:35 PST
> From what I can see, Netflix works in the current trunk nightly when
> I change the UA to 9.0.1.

That's good news.  I hope you tested on a machine where you're able to
reproduce the problem with "genuine" FF 9.0.1.
Comment 26 Marcia Knous [:marcia - use ni] 2012-01-11 18:05:29 PST
Yes, testing on the same 10.6 machine where I was able to reproduce on the real mcoy:  Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:9.0.1) Gecko/20100101 Firefox/9.0.1.

(In reply to Steven Michaud from comment #25)
> > From what I can see, Netflix works in the current trunk nightly when
> > I change the UA to 9.0.1.
> 
> That's good news.  I hope you tested on a machine where you're able to
> reproduce the problem with "genuine" FF 9.0.1.
Comment 27 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-11 20:07:39 PST
Changing Firefox 9.0.1's user agent to match Safari 5.0.5 [ Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_8; de-at) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1 ] based on info from : http://www.useragentstring.com/pages/Safari/ allows the video to play ( I had to log out of netflix first )  In fact, using the string that you provided worked as well.  

What did not work was the default User Agent.  Could it be that there was some kind of control character introduced inside the User Agent that is installed with 9.0?
Comment 28 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-11 20:15:23 PST
Please ignore the part about the control character.  It appears that something was cached.  

The safari user agent does work with 9.0.1.
Comment 29 Verdi [:verdi] 2012-01-11 20:22:57 PST
I had the latest silverlight (5.0.61118.0) installed on a 2008 MBP with OS 10.6.8 and Firefox 9.0.1. Netflix would not play (just got a black screen). I quit Firefox and and restarted it in 32-bit mode. Then Netflix videos played just fine.
Comment 30 Steven Michaud [:smichaud] (Retired) 2012-01-12 07:52:26 PST
Marcia and Naoki, were you testing in 64-bit mode?  Does FF 9.0.1 also
work for you in 32-bit mode on machines where it doesn't work in
64-bit mode?  (Here I'm talking about tests with the default
user-agent string.)

As I understand it, Silverlight uses the Cocoa event model when it
thinks it's running in Firefox, but otherwise uses the Carbon event
model.	I suspect Silverlight uses the Carbon event model in FF 9.0.1
when you make FF 9.0.1 use the Safari user-agent string.  So it seems
this bug only happens when Silverlight uses the Cocoa event model.

So the puzzle is why Silverlight works in current trunk code with the
FF 9.0.1 user-agent string, when presumably it's using the Cocoa event
model.  It's very important to find out when this change happened
(i.e. to find the "degression" range) -- even more important than
finding the regression range.  (Though of course it'd be nice to have
both.)  Remember that when finding the degression and regression
ranges, you'll need to test with FF 9.0.1's user-agent string.
Comment 31 Steven Michaud [:smichaud] (Retired) 2012-01-12 08:13:26 PST
And needless to say, all tests should be done with the current version of Silverlight (5.0.61118.0).
Comment 32 Marcia Knous [:marcia - use ni] 2012-01-12 09:36:15 PST
Yes, I was testing in 64-bit mode. I will do some tests today in 32.
Comment 33 Verdi [:verdi] 2012-01-12 10:12:41 PST
At Cheng's suggestion I tested Firefox 8.0.1, 10b3, 11, and 12 in 64bit mode and with the default UA and they could all play netflix movies with silverlight (5.0.61118.0). I also tried all of them with the 9.0.1 UA and again they could all play netflix movies.
Comment 34 Verdi [:verdi] 2012-01-12 10:23:31 PST
I just went back and tested Firefox 8.0.1, 10b3, 11, and 12 in 32bit mode with both the default UA and the 9.0.1 UA and they were all able to play netflix movies.

So far the only combination that I've been able to reproduce the problem with is 9.0.1 in 64bit mode.
Comment 35 Naoki Hirata :nhirata (please use needinfo instead of cc) 2012-01-12 10:26:47 PST
(In reply to Steven Michaud from comment #30)
> Marcia and Naoki, were you testing in 64-bit mode?  Does FF 9.0.1 also
> work for you in 32-bit mode on machines where it doesn't work in
> 64-bit mode?  (Here I'm talking about tests with the default
> user-agent string.)

Yes, I was using 64 bit mode.  on 10.7, it stated that I had to use Silverlight in 32 bit mode and worked.  on 10.6, it didn't state that at all.
Comment 36 Verdi [:verdi] 2012-01-12 10:34:19 PST
For the record, all the tests I did were on a late 2008 MBP (first unibody model) running Mac OS 10.6.8
Comment 37 Marcia Knous [:marcia - use ni] 2012-01-12 11:37:42 PST
Testing with the lab machine where I was able to reproduce the issue, Firefox 9.0.1 plays video fine in 32 mode but not in 64-bit mode. Testing with Version: 5.0.61118.0.

I also tested with Firefox 9 and I see different behavior in Firefox 9 versus 9.0.1 relating to Netflix. Loading Netflix in 9.0 I do not see a black screen, but I at least see the Netflix player. This is in 64-bit. Attaching a screenshot shortly.
Comment 38 Marcia Knous [:marcia - use ni] 2012-01-12 11:38:19 PST
Created attachment 588130 [details]
Screenshot of Netflix in Firefox 9.0 64-bit
Comment 39 Steven Michaud [:smichaud] (Retired) 2012-01-12 11:47:49 PST
It'd be worth doing some tests with the FF 9 user-agent string (as opposed to the FF 9.0.1 user-agent string).
Comment 40 Verdi [:verdi] 2012-01-12 11:50:00 PST
(In reply to Marcia Knous [:marcia] from comment #37)
> Testing with the lab machine where I was able to reproduce the issue,
> Firefox 9.0.1 plays video fine in 32 mode but not in 64-bit mode. Testing
> with Version: 5.0.61118.0.
> 
> I also tested with Firefox 9 and I see different behavior in Firefox 9
> versus 9.0.1 relating to Netflix. Loading Netflix in 9.0 I do not see a
> black screen, but I at least see the Netflix player. This is in 64-bit.
> Attaching a screenshot shortly.

I just tested 9 on my machine and didn't see this. I got the same results as 9.0.1 - works in 32-bit mode, black screen in 64-bit mode.
Comment 41 Steven Michaud [:smichaud] (Retired) 2012-01-12 12:52:42 PST
I've written a debugging patch, and have been playing around with Silverlight examples at http://www.silverlight.net/showcase.  Testing on OS X 10.6.8 in 64-bit mode, it tells me that, in current trunk code, the current version of Silverlight always uses the Cocoa event model (and the CoreGraphics drawing model), regardless of what user-agent string you use.

I'll apply my debugging patch to FF 9.0.1 and 9.0 code, and see what results I get.
Comment 42 Steven Michaud [:smichaud] (Retired) 2012-01-12 12:57:55 PST
I've also confirmed that Silverlight 5.0.61118.0 doesn't turn on plugin caching.  So, as far as browser code is concerned, there isn't any difference for Silverlight between FF 9.0 and FF 9.0.1.
Comment 43 Steven Michaud [:smichaud] (Retired) 2012-01-13 10:08:20 PST
(Following up comment #30)

> As I understand it, Silverlight uses the Cocoa event model when it
> thinks it's running in Firefox, but otherwise uses the Carbon event
> model.

Turns out this is wrong for both Silverlight 5.0.6118.0 and
Silverlight 4.0.6831.0 (which I	believe to be the last v4 version, and
was released late last year).  I found this out by testing with my
debugging patch in current trunk code, FF 9.0.1 code and FF 9.0 code.

In 64-bit mode, Silverlight (v5 or v4) always uses the Cocoa event
model with all three of these builds.

Interestingly though, in 32-bit mode Silverlight always uses the
Carbon event model.  (Actually it doesn't request any event model,
which means that we default to using the Carbon event model in 32-bit
mode.)  This makes sense, because (as I didn't remember earlier) the
Carbon event model is incompatible with our implementation of IPC, so
(Silverlight being 32-bit only on the Mac) the Carbon event model
won't work in 64-bit mode.

So it looks like what I said about the user-agent string was a red
herring.  Silverlight may still attention to it, but not in the way it
used to.
Comment 44 Steven Michaud [:smichaud] (Retired) 2012-01-13 10:16:44 PST
I wonder if Silverlight settings/preferences could make a difference
here -- particularly settings inherited from earlier versions of
Silverlight.

Silverlight preferences live in
~/Library/Preferences/com.microsoft.silverlight.plist.	And
Silverlight stores other information in	~/Library/Application
Support/Microsoft/Silverlight/.

Whoever can reproduce this bug, please try again after having renamed
this file and directory.
Comment 45 Steven Michaud [:smichaud] (Retired) 2012-01-13 11:27:33 PST
(Following up comment #43)

Another interesting thing I discovered (that I forgot to mention above):

In 32-bit mode Silverlight turns on plugin caching.  It doesn't do this in 64-bit mode.
Comment 46 Marcia Knous [:marcia - use ni] 2012-01-18 16:39:34 PST
Renaming both of those directories did not make a difference in my case. Testing on one of the same 10.6 lab machines where I was able to reproduce the issue.

(In reply to Steven Michaud from comment #44)
> I wonder if Silverlight settings/preferences could make a difference
> here -- particularly settings inherited from earlier versions of
> Silverlight.
> 
> Silverlight preferences live in
> ~/Library/Preferences/com.microsoft.silverlight.plist.	And
> Silverlight stores other information in	~/Library/Application
> Support/Microsoft/Silverlight/.
> 
> Whoever can reproduce this bug, please try again after having renamed
> this file and directory.
Comment 47 Verdi [:verdi] 2012-01-19 09:27:01 PST
From the support forum - user with Mac OS 10.6, Silverlight 5 and Firefox 9.0.1 - solved by running Fx in 32-bit mode https://support.mozilla.org/en-US/questions/913702
Comment 48 Alex Keybl [:akeybl] 2012-01-20 13:56:24 PST
(In reply to Verdi from comment #47)
> From the support forum - user with Mac OS 10.6, Silverlight 5 and Firefox
> 9.0.1 - solved by running Fx in 32-bit mode
> https://support.mozilla.org/en-US/questions/913702

In that case, let's relnote/SUMO for FF10.
Comment 50 godzfire 2012-01-20 16:58:31 PST
Edit: Nevermind, please delete comment 49 and this post, I made a mistake.
Comment 51 Alex Keybl [:akeybl] 2012-01-30 12:09:22 PST
We're relnoting for FF10 - sending to Steven for further investigation.
Comment 52 Steven Michaud [:smichaud] (Retired) 2012-01-30 13:43:33 PST
> sending to Steven for further investigation

I can't do much further investigation, since I can't reproduce this bug -- my Netflix account doesn't support streaming.
Comment 53 Steven Michaud [:smichaud] (Retired) 2012-02-01 15:03:06 PST
OK, I now have access to a Netflix account that supports streaming.
But I still can't reproduce this bug.

I tested on OS X 10.6.8 with FF 10.0 and today's mozilla-central
nightly, in 64-bit mode (the default).  I logged on to Netflix and
then clicked on one of the movies displayed -- which caused it to
start streaming.  All my tests started in non-fullscreen mode.  But
switching to and from Silverlight's fullscreen mode seemed to make no
difference.  I never saw any problems.

The 6-months-old MacBook Pro I tested with has two different kinds of
video hardware.  From the System Profiler:

AMD Radeon HD 6750M
Intel HD Graphics 3000 (built-in)

I used the gfxCardStatus app (http://codykrieger.com/gfxCardStatus) to
force Firefox to use one or the other of these graphics "cards".  It
made no difference -- I didn't see any problems with either graphics
"card".

My Silverlight version is 5.0.61118.0 (which I believe is current).
Comment 54 Verdi [:verdi] 2012-02-01 15:11:21 PST
(In reply to Steven Michaud from comment #53)
> OK, I now have access to a Netflix account that supports streaming.
> But I still can't reproduce this bug.
> 
> I tested on OS X 10.6.8 with FF 10.0 and today's mozilla-central
> nightly, in 64-bit mode (the default).  

Try using Fx 9.0.1. I was only able to reproduce this issue with 9.0.1.
Comment 55 Steven Michaud [:smichaud] (Retired) 2012-02-01 15:34:47 PST
I can't reproduce using FF 9.0.1, either.

So Verdi, are you telling us you can no longer reproduce this bug in FF 10.0?
Comment 56 Verdi [:verdi] 2012-02-01 15:54:44 PST
(In reply to Steven Michaud from comment #55)
> I can't reproduce using FF 9.0.1, either.
> 
> So Verdi, are you telling us you can no longer reproduce this bug in FF 10.0?

I did a bunch of testing a couple of weeks ago - comment #33 comment #34 and comment #36 and I was only able to reproduce this with 9.0.1 running on Mac OS 10.6.8 on a late 2008 unibody 15" MBP.

I haven't tested this again since then. I can try it with Fx 10 later this evening.
Comment 57 Verdi [:verdi] 2012-02-02 07:31:21 PST
(In reply to Steven Michaud from comment #55)
> I can't reproduce using FF 9.0.1, either.
> 
> So Verdi, are you telling us you can no longer reproduce this bug in FF 10.0?

I just tested again: 2008 unibody MBP running 10.6.8. I tried Netflix streaming using 9.0.1 64-bit mode - black screen. Download update to 10.0 and restarted. Netflix streaming worked as expected. 

One other note: The graphics settings under Energy Saver are set to "Higher Performace" so I guess that means the computer is using the NVIDIA GeForce 9600M GT instead of the NVIDIA GeForce 9400M
Comment 58 Steven Michaud [:smichaud] (Retired) 2012-02-02 09:05:53 PST
> I just tested again: 2008 unibody MBP running 10.6.8. I tried
> Netflix streaming using 9.0.1 64-bit mode - black screen. Download
> update to 10.0 and restarted. Netflix streaming worked as expected.

Thanks for the info.  On the strength of this and what you said in
comment #34, I'm marking this bug WORKSFORME. 	

But we still don't know whether (or how) the Silverlight plugin still
attempts to sniff which browser it's running in, and if so how it
behaves differently if it thinks it's running in Firefox.  So there's
a chance (hopefully only a small chance) that this bug will show up
again in FF 11.

> One other note: The graphics settings under Energy Saver are set to
> "Higher Performace" so I guess that means the computer is using the
> NVIDIA GeForce 9600M GT instead of the NVIDIA GeForce 9400M

Not necessarily.  The only way to be sure which	graphics hardware
Firefox is using is with the gfxCardStatus app mentioned in comment
#53.  And even that app sometimes doesn't work properly unless you set
it to load on startup (the default) and reboot your computer.

Please use it to test FF with both kinds of graphics hardware.	If you
find that you can still reproduce this bug with one of them, in FF
10.0, please reopen this bug.
Comment 59 saralhirsch 2015-01-25 16:14:44 PST
Hello Mozilla/FIREFOX I just updated to your latest version and now my NETFLIX nor my YOUTUBE plays anymore. I just get a black space without any volume or play symbols - this isn't working for me. I donated to your organization as I am a supporter but you'll need to honor your side of the street. What are you guys doing to fix this and by when will it be resolved?
Comment 60 Verdi [:verdi] 2015-01-26 06:35:16 PST
Hi,
Please ask the support folks about this issue. They can collect information about your setup and should be able to help - https://support.mozilla.org/en-US/questions/new/desktop
Comment 61 saralhirsch 2015-01-26 07:50:57 PST
Hi Verdi, is this not just what I did? Sorry I am not very familiar with asking for help in a support system like this, I usually have access to customer service. How do I reach the support folks you mean?
Comment 62 Verdi [:verdi] 2015-01-26 11:18:49 PST
(In reply to saralhirsch from comment #61)
> Hi Verdi, is this not just what I did? Sorry I am not very familiar with
> asking for help in a support system like this, I usually have access to
> customer service. How do I reach the support folks you mean?

Sorry - what you did was comment on an issue (but report) that was resolved about 3 years ago. The support folks use a different website (https://support.mozilla.org). You can also access it from Firefox by going to the help menu and choosing Firefox Help.

This is a direct link to the place to ask a question about Desktop Firefox - https://support.mozilla.org/questions/new/desktop

Note You need to log in before you can comment on or make changes to this bug.