Closed Bug 715457 Opened 9 years ago Closed 9 years ago

HTML5 youtube video on pause starts playing when expand/reduce the player

Categories

(Core :: Audio/Video, defect)

10 Branch
defect
Not set
normal

Tracking

()

VERIFIED INVALID

People

(Reporter: pauly, Unassigned)

Details

(Whiteboard: [10b3])

Steps to reproduce:
1. Launch Firefox 10b3
2. Join the HTML5 Trial http://www.youtube.com/html5
3. Open http://www.youtube.com/watch?v=kkGeOWYOFoA
4. Pause and then expand

Actual results:
Video starts playing

Expected results:
Video still paused
I am unable to reproduce this bug using the latest Nightly. Can you confirm this bug is reproducible?
Status: NEW → UNCONFIRMED
Ever confirmed: false
Yes, I do. The issue is also reproducible on latest Nightly:
Build identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:12.0a1) Gecko/20120105 Firefox/12.0a1
To be more specific, at step 4, by "expand" I mean "large player" button, not fullscreen button.
But the issue seems to be reproducible also on Opera and Chrome. However strange it works fine on IE9 and Safari.
What if you spoof your user agent to IE9 or Safari? Also, does this happen for any other sites which stream HTML5 video?
I can't find other sites with expand/reduce html5 video function
Paul, you didn't answer my first question...what about User Agent string spoofing?
The video in comment 0 is served using Flash for me.  I can reproduce this using a video using an HTML5 video: http://www.youtube.com/watch?v=Ks781rIsObI

I also see this behaviour in Chrome and Opera, so it's either intended behaviour (unlikely, as it differs from the Flash player) or a bug in the YouTube HTML5 player.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → INVALID
Works OK with Firefox user agent changed to IE7 and 8. Doesn't work with IE9 and Safari
Given that, I concur with comment 7.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.