Last Comment Bug 715513 - [Azure] Implement text in Cairo backend
: [Azure] Implement text in Cairo backend
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Graphics (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal (vote)
: mozilla12
Assigned To: Joe Drew (not getting mail)
:
Mentors:
Depends on:
Blocks: 694351
  Show dependency treegraph
 
Reported: 2012-01-05 08:12 PST by Joe Drew (not getting mail)
Modified: 2012-01-11 18:09 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
font support (12.24 KB, patch)
2012-01-05 08:12 PST, Joe Drew (not getting mail)
jmuizelaar: review+
Details | Diff | Splinter Review
override skia fonts (700 bytes, patch)
2012-01-05 08:13 PST, Joe Drew (not getting mail)
no flags Details | Diff | Splinter Review

Description Joe Drew (not getting mail) 2012-01-05 08:12:41 PST
Created attachment 586092 [details] [diff] [review]
font support

This patch implements text in the Canvas backend, both filled and text-to-path. In a build with the other patches implementing the Cairo backend as well as this patch, we still don't use this code, though, because on OS X we unconditionally do Skia fonts for ScaledFont. We'll need to resolve this problem before we can use this backend.
Comment 1 Joe Drew (not getting mail) 2012-01-05 08:13:34 PST
Created attachment 586093 [details] [diff] [review]
override skia fonts

This patch overrides OS X using Skia ScaledFonts by default, so this patch can actually be tested.
Comment 2 Jeff Muizelaar [:jrmuizel] 2012-01-05 08:34:58 PST
(In reply to Joe Drew (:JOEDREW!) from comment #0)
> Created attachment 586092 [details] [diff] [review]
> font support
> 
> This patch implements text in the Canvas backend, both filled and
> text-to-path. In a build with the other patches implementing the Cairo
> backend as well as this patch, we still don't use this code, though, because
> on OS X we unconditionally do Skia fonts for ScaledFont. We'll need to
> resolve this problem before we can use this backend.

I plan on resolving this as part of the CG backend landing.
Comment 3 Jeff Muizelaar [:jrmuizel] 2012-01-05 12:06:49 PST
Comment on attachment 586092 [details] [diff] [review]
font support

Review of attachment 586092 [details] [diff] [review]:
-----------------------------------------------------------------

::: gfx/2d/Types.h
@@ +95,5 @@
>    NATIVE_FONT_DWRITE_FONT_FACE,
>    NATIVE_FONT_GDI_FONT_FACE,
>    NATIVE_FONT_MAC_FONT_FACE,
> +  NATIVE_FONT_SKIA_FONT_FACE,
> +  NATIVE_FONT_GFX_FONT_FACE

NATIVE_FONT_CAIRO_FONT_FACE is preferred.
Comment 4 Joe Drew (not getting mail) 2012-01-10 19:43:10 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/603df6854a52
Comment 5 Ed Morley [:emorley] 2012-01-11 18:09:08 PST
https://hg.mozilla.org/mozilla-central/rev/603df6854a52

Note You need to log in before you can comment on or make changes to this bug.