Last Comment Bug 715543 - Fix the debugger after the latest merge from fx-team
: Fix the debugger after the latest merge from fx-team
Status: RESOLVED FIXED
:
Product: Firefox
Classification: Client Software
Component: Developer Tools: Debugger (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Panos Astithas [:past]
:
: James Long (:jlongster)
Mentors:
Depends on:
Blocks: 697762
  Show dependency treegraph
 
Reported: 2012-01-05 09:22 PST by Panos Astithas [:past]
Modified: 2012-01-10 01:20 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
WIP (1.01 KB, patch)
2012-01-05 09:23 PST, Panos Astithas [:past]
no flags Details | Diff | Splinter Review
Working patch (9.93 KB, patch)
2012-01-09 08:39 PST, Panos Astithas [:past]
no flags Details | Diff | Splinter Review
Working patch v2 (10.64 KB, patch)
2012-01-09 09:34 PST, Panos Astithas [:past]
dcamp: review+
Details | Diff | Splinter Review

Description Panos Astithas [:past] 2012-01-05 09:22:37 PST
After the merge from fx-team in changeset bf0bae1ca857 the debugger does not start and tests fail.
Comment 1 Panos Astithas [:past] 2012-01-05 09:23:50 PST
Created attachment 586114 [details] [diff] [review]
WIP

With the attached patch the debugger works, but one test still fails:

TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_script-switching.js | The correct script was loaded initially.
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/debugger/test/browser_dbg_script-switching.js | The second script is displayed again.

This seems to be caused because the scripts are only partially loaded in the editor, like in bug 713359.
Comment 2 Panos Astithas [:past] 2012-01-09 08:39:45 PST
Created attachment 587011 [details] [diff] [review]
Working patch

Fixed the last failing test, by using the fix from bug 713359. Also made the test more robust, by determining script loaded status using SourceEditor events.
Comment 3 Panos Astithas [:past] 2012-01-09 09:34:47 PST
Created attachment 587022 [details] [diff] [review]
Working patch v2

Fixed another bug I found during testing, caused by the recently added Debugger.Environment.

Note You need to log in before you can comment on or make changes to this bug.