Closed Bug 71560 Opened 24 years ago Closed 23 years ago

Need bugzilla mail header with all the fields that were changed

Categories

(Bugzilla :: Email Notifications, enhancement, P2)

2.13
enhancement

Tracking

()

VERIFIED DUPLICATE of bug 70710

People

(Reporter: shaver, Assigned: jacob)

Details

So that people can filter more specifically, thereby reducing the amount of
bugmail they have to wade through by hand, and in turn improving hacker
productivity!  It's win-win-win!

Or something.

X-Bugzilla-Fields: new
X-Bugzilla-Fields: comment,cc,keywords
X-Bugzilla-Fields: comment,qa-contact

etc.
Target Milestone: --- → Bugzilla 2.16
See also similar bug 70710 and bug 26194.
Priority: -- → P2
Mass moving to new product Bugzilla...
Assignee: tara → jake
Component: Bugzilla → Email
Product: Webtools → Bugzilla
Version: Bugzilla 2.11 → 2.13
Shaver: how about one header per field that has changed? Like:

X-Bugzilla-Changed: Status
X-Bugzilla-Changed: Resolution

etc., etc.? I have a patch for this; need to test it though. Concatenation (like
you proposed) seems less elegant to me, but I'm flexible if people on the cc
list have thoughts/comments.

Also, I recommend everyone on this cc look at 70710; I've posted some diffs
there (soon to be updated) that would add a number of useful status headers to
bugzilla email and I'd like a bit of feedback. 
Why would we want one per line?  I don't see it.  We already have
X-Bugzilla-Reasons, it uses space separation.
I hadn't actually noticed that X-Bugzilla-Reasons uses spaces; that would be
fine with me. 
Patch against bug 70710 now implements this (space delimited); marking this a
duplicate of that one unless anyone objects.

*** This bug has been marked as a duplicate of 70710 ***
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → DUPLICATE
clearing target milestone on resolved non-FIXED bugs so they'll get re-triaged
if they get reopened.
Target Milestone: Bugzilla 2.16 → ---
Verified dupe
Status: RESOLVED → VERIFIED
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.