Last Comment Bug 715645 - add makefile vars to disable Makefile regeneration rules
: add makefile vars to disable Makefile regeneration rules
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Ted Mielczarek [:ted.mielczarek]
:
Mentors:
Depends on:
Blocks: 643692
  Show dependency treegraph
 
Reported: 2012-01-05 13:22 PST by Ted Mielczarek [:ted.mielczarek]
Modified: 2012-03-13 10:07 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Add Makefile vars to skip the rules that regenerate Makefiles from Makefile.in (5.47 KB, patch)
2012-01-05 13:23 PST, Ted Mielczarek [:ted.mielczarek]
khuey: review+
Details | Diff | Review

Description Ted Mielczarek [:ted.mielczarek] 2012-01-05 13:22:28 PST
I'm doing some funny things in bug 643692, generating Makefiles directly into the objdir from .gyp files, without Makefile.ins in the srcdir. Our build system gets confused when there's no Makefile.in to rebuild from, so I have a patch that lets us selectively disable that.
Comment 1 Ted Mielczarek [:ted.mielczarek] 2012-01-05 13:23:00 PST
Created attachment 586193 [details] [diff] [review]
Add Makefile vars to skip the rules that regenerate Makefiles from Makefile.in

Pretty simple patch, it WFM.
Comment 2 Ted Mielczarek [:ted.mielczarek] 2012-01-06 04:50:37 PST
Comment on attachment 586193 [details] [diff] [review]
Add Makefile vars to skip the rules that regenerate Makefiles from Makefile.in

I'm using this in my GYP-generated Makefiles and it seems to be working well.
Comment 3 Ted Mielczarek [:ted.mielczarek] 2012-01-19 12:31:13 PST
I landed this on alder:
http://hg.mozilla.org/projects/alder/rev/3ad14f5fed4c

It'll get back to m-c eventually.

Note You need to log in before you can comment on or make changes to this bug.