browserid: register new user fails the first time?

VERIFIED FIXED in 2.0

Status

Mozilla Developer Network
Wiki pages
VERIFIED FIXED
6 years ago
5 years ago

People

(Reporter: groovecoder, Assigned: groovecoder)

Tracking

unspecified
x86
Mac OS X

Details

(Whiteboard: u=user c=browserid p=2 pa=3)

(Assignee)

Description

6 years ago
[Django] Error (EXTERNAL IP): /en-US/users/browserid_register         

Traceback (most recent call last):

  File "/data/www/django/developer.mozilla.org/kuma/vendor/src/django/django/core/handlers/base.py", line 100, in get_response
    response = callback(request, *callback_args, **callback_kwargs)

  File "/data/www/django/developer.mozilla.org/kuma/apps/sumo/decorators.py", line 15, in _checkssl
    return view_func(request, *args, **kwargs)

  File "/data/www/django/developer.mozilla.org/kuma/apps/users/views.py", line 181, in browserid_register
    profile.deki_user_id = deki_user.id

AttributeError: 'NoneType' object has no attribute 'id'

http://pastebin.mozilla.org/1435777
(Assignee)

Updated

6 years ago
Assignee: nobody → lcrouch
Having trouble reproducing this on dev, stage9, or prod. Could be a single failing Mindtouch API webhead? Maybe a fix is to wrap some further robustness & retries around the Django code hitting the MT API? (Ugh)
(Assignee)

Updated

6 years ago
Duplicate of this bug: 716064
(Assignee)

Comment 3

6 years ago
I can't reproduce reliably either, but we get a couple of server-error emails on this per day. :( It affects both en-US/users/browserid_register and */users/register
(Assignee)

Updated

6 years ago
Whiteboard: u=user c=browserid p= → u=user c=browserid p=2

Comment 4

6 years ago
Commits pushed to https://github.com/mozilla/kuma

https://github.com/mozilla/kuma/commit/0ca339fe9073b992d40216a48beed581249f10df
Fix Bug 715708 mark test skip so someday we remember to fix it

https://github.com/mozilla/kuma/commit/11eec26e2464b22713f05645aec7ae6e3bd065f5
Fix Bug 715708 move retry wait to constance; fix test weirdness

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
(Assignee)

Updated

6 years ago
Whiteboard: u=user c=browserid p=2 → u=user c=browserid p=2 pa=3
verified fixed in both en-US and FR

https://developer.mozilla.org/fr/users/register
Status: RESOLVED → VERIFIED
Version: Kuma → unspecified
Component: Website → Landing pages
Product: Mozilla Developer Network → Mozilla Developer Network
You need to log in before you can comment on or make changes to this bug.