Last Comment Bug 715769 - Kill unused enums nsWidgetType and nsLanguageSpecificTransformType
: Kill unused enums nsWidgetType and nsLanguageSpecificTransformType
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: CSS Parsing and Computation (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Jonathan Watt [:jwatt]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-05 18:42 PST by Jonathan Watt [:jwatt]
Modified: 2012-01-16 20:02 PST (History)
1 user (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch (1.08 KB, patch)
2012-01-05 18:44 PST, Jonathan Watt [:jwatt]
bernd_mozilla: review+
Details | Diff | Review

Description Jonathan Watt [:jwatt] 2012-01-05 18:42:54 PST
It seems like the enums enums nsLanguageSpecificTransformType and nsPresContext_CachedBoolPrefType are no longer used and can be removed.
Comment 1 Jonathan Watt [:jwatt] 2012-01-05 18:44:06 PST
Created attachment 586313 [details] [diff] [review]
patch
Comment 2 Bernd 2012-01-05 22:46:31 PST
Comment on attachment 586313 [details] [diff] [review]
patch

Review of attachment 586313 [details] [diff] [review]:
-----------------------------------------------------------------

nsLanguageSpecificTransformType is a incomplete removal in bug 458984 
nsWidgetType has not been used since its introduction
Comment 3 Bernd 2012-01-05 22:47:29 PST
the bug title indicates that you want to remove nsPresContext_CachedBoolPrefType  too but thats not part of the patch
Comment 4 Jonathan Watt [:jwatt] 2012-01-06 03:24:21 PST
Sorry, I meant nsWidgetType, not nsPresContext_CachedBoolPrefType. The patch is correct.

I ran the patch through Try to double check that there weren't any build failures due to the enums being used, hidden behind some macros or something:

https://tbpl.mozilla.org/?tree=Try&rev=bc558a25e5a6

Sorry about getting your email address wrong. You might want to correct it on https://wiki.mozilla.org/Modules/Core to the one you prefer.
Comment 5 Justin Wood (:Callek) 2012-01-16 20:02:25 PST
https://hg.mozilla.org/mozilla-central/rev/ce914679955e (from inbound merge)

Note You need to log in before you can comment on or make changes to this bug.