Last Comment Bug 715783 - delay load for comdlg32 and winspool
: delay load for comdlg32 and winspool
Status: RESOLVED FIXED
[inbound]
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: x86 Windows Vista
: -- normal (vote)
: mozilla12
Assigned To: Makoto Kato [:m_kato] (PTO 9/22-9/25)
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-05 19:57 PST by Makoto Kato [:m_kato] (PTO 9/22-9/25)
Modified: 2012-02-01 13:56 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (529 bytes, patch)
2012-01-05 20:48 PST, Makoto Kato [:m_kato] (PTO 9/22-9/25)
khuey: review+
Details | Diff | Splinter Review

Description Makoto Kato [:m_kato] (PTO 9/22-9/25) 2012-01-05 19:57:24 PST
Both should be delay loaded dll.  Becauses comdlg32 is for common dialog such as file open dialog and winspool is for printing.
Comment 1 Makoto Kato [:m_kato] (PTO 9/22-9/25) 2012-01-05 20:48:08 PST
Created attachment 586338 [details] [diff] [review]
fix
Comment 2 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2012-01-07 15:51:49 PST
Comment on attachment 586338 [details] [diff] [review]
fix

Review of attachment 586338 [details] [diff] [review]:
-----------------------------------------------------------------

r=me if you verify that with this patch we start up without loading these DLLs.
Comment 3 Makoto Kato [:m_kato] (PTO 9/22-9/25) 2012-01-09 22:31:27 PST
(In reply to Kyle Huey [:khuey] (khuey@mozilla.com) from comment #2)
> Comment on attachment 586338 [details] [diff] [review]
> fix
> 
> Review of attachment 586338 [details] [diff] [review]:
> -----------------------------------------------------------------
> 
> r=me if you verify that with this patch we start up without loading these
> DLLs.

I tested on Win7.  Both aren't loaded at startup by this fix.
Comment 4 Makoto Kato [:m_kato] (PTO 9/22-9/25) 2012-01-09 22:44:05 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/167afff96b0d
Comment 5 Ed Morley [:emorley] 2012-01-10 11:50:54 PST
https://hg.mozilla.org/mozilla-central/rev/167afff96b0d

Note You need to log in before you can comment on or make changes to this bug.