Closed Bug 715809 Opened 8 years ago Closed 7 years ago

AppCache should accept manifests served with non-standard mime types

Categories

(Core :: Networking: Cache, defect)

11 Branch
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla20
Tracking Status
firefox19 --- fixed
b2g18 --- fixed

People

(Reporter: bent.mozilla, Assigned: mayhemer)

References

Details

Attachments

(1 file, 1 obsolete file)

Attached patch Patch, v1 (obsolete) — Splinter Review
Apparently this is hard for some web hosting customers or something. No real reason to restrict this as far as I can tell.
Attachment #586345 - Flags: review?(jonas)
As reported in bug 721655, the spec has changed [1], so the patch for me is clearly an r+.

[1] http://html5.org/tools/web-apps-tracker?from=6919&to=6920
Duplicate of this bug: 721655
I believe we have tests that check the correctness of the mime type.  Should be removed along with the code.
Duplicate of this bug: 733937
Any progress here??
Crap, i thought this had landed. Yes, we should definitely do this for FF15
Are you chasing the price for the longest time waiting patch to land? :)
Comment on attachment 586345 [details] [diff] [review]
Patch, v1

This patch is correct but tests are totally borked by it. We need to investigate the test failures before this can land and I don't have time currently.
Attachment #586345 - Flags: review+
We should land this tiny change at last.

Stealing the bug.
Assignee: bent.mozilla → honzab.moz
Attached patch v2Splinter Review
Try: https://tbpl.mozilla.org/?tree=Try&rev=b2492bbbe91e
Attachment #586345 - Attachment is obsolete: true
Attachment #695197 - Flags: review?(jonas)
https://hg.mozilla.org/mozilla-central/rev/a0cda99c4087
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla20
Honza - Would this be worth nominating for b2g18? This would resolve an annoying marketplace hosted app issue you probably saw that we have hosted apps getting submitted with appcache manifests with an incorrect mime type.
Comment on attachment 695197 [details] [diff] [review]
v2

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky): 
String or UUID changes made by this patch:
Attachment #695197 - Flags: approval-mozilla-b2g18?
[Approval Request Comment]
Bug caused by (feature/regressing bug #): none
User impact if declined: since the offline app spec for a long time doesn't require the mime type, lots of developers don't add it on the server, so we will fail to load offline caches for potentially important 3rd party web applications leading to bad user experience and putting additional and not necessary effort to our web developers as well as 3rd party developers
Testing completed: just landed on m-c
Risk to taking this patch (and alternatives if risky): *cold zero*
String or UUID changes made by this patch: none
Comment on attachment 695197 [details] [diff] [review]
v2

[Triage Comment]
Given the risk/reward here, let's land on Aurora 19 and B2G18.
Attachment #695197 - Flags: approval-mozilla-b2g18?
Attachment #695197 - Flags: approval-mozilla-b2g18+
Attachment #695197 - Flags: approval-mozilla-aurora+
Blocks: 827107
Duplicate of this bug: 827107
Please don't forget to uplift this to the b2g18 branch.
(In reply to Jonas Sicking (:sicking) from comment #21)
> Please don't forget to uplift this to the b2g18 branch.

Isn't that what comment 19 did? Looks like the patch was landed on Aurora and b2g 18 in that comment.
Ah, indeed! But the flags weren't updated appropriately. Thanks for landing!
You need to log in before you can comment on or make changes to this bug.