If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Maintain scroll position of page on rotation

RESOLVED DUPLICATE of bug 755770

Status

()

Firefox for Android
Graphics, Panning and Zooming
P3
normal
RESOLVED DUPLICATE of bug 755770
6 years ago
5 years ago

People

(Reporter: aaronmt, Assigned: kats)

Tracking

Trunk
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox16 affected, firefox17 affected, firefox18 affected, fennec+)

Details

(Whiteboard: [parity-stock], [testday-20120106])

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Created attachment 586422 [details]
Nightly (01/06) screenshot

Scroll position should be maintained after a device rotation. Fennec will scroll down a bit switching from portait to landscape, and back to portrait.

See screenshot taken from mail.yahoo.com, scroll position in the third frame should be equal to the first frame going from portrait to landscape to portrait.

--
Samsung Nexus S (Android 4.0.3)
Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120106 Firefox/12.0a1 Fennec/12.0a1
Mozilla/5.0 (Android; Linux armv7l; rv:11.0a2) Gecko/20120106 Firefox/11.0a2 Fennec/11.0a2
(Reporter)

Updated

6 years ago
status-firefox11: --- → affected
status-firefox12: --- → affected
Assignee: nobody → chrislord.net
tracking-fennec: --- → 11+
Priority: -- → P3

Comment 1

6 years ago
ehshan fixed this in Maple, do we still care that this happens in nightly? I don't think we'll be releasing a version (or beta) using the Java compositor, so fixing this might be wasted effort.

Comment 2

6 years ago
Maple has merged now, so this is fixed.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
I'm seeing this behaviour again in the current release and nightly.
This issue is still reproducing on the latest Nightly build. 

STR:
1. Go to cnn.com in portrait
2. Rotate device to landscape
3. Rotate it back to portrait.

Actual result: Page is scrolled down just below the CNN header.

Reopening bug

--
Firefox 18.0a1 (2012-08-29)
Device: Galaxy Note
OS: Android 4.0.4
Status: RESOLVED → REOPENED
tracking-fennec: 11+ → ?
status-firefox11: affected → ---
status-firefox12: affected → ---
status-firefox16: --- → affected
status-firefox18: --- → affected
Component: General → Graphics, Panning and Zooming
Resolution: FIXED → ---
(Reporter)

Comment 5

5 years ago
I can't reproduce this on the same build, device and site. Can you target a check-in and or reproduce reliably?
(In reply to Aaron Train [:aaronmt] from comment #5)
> I can't reproduce this on the same build, device and site. Can you target a
> check-in and or reproduce reliably?

Try to open an article from the CNN home in portrait and it should occur on Nightly. On the Beta it is reproducing with the str from comment #4.
This issue is still reproducing on the latest Beta build as you can see here: http://youtu.be/tcme7UkDP4Y

--
Firefox 16.0b2 build 2 (2012-09-06)
Device: Galaxy Note
OS: Android 4.0.4
status-firefox17: --- → affected
Assignee: chrislord.net → bugmail.mozilla
tracking-fennec: ? → +
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 755770
You need to log in before you can comment on or make changes to this bug.