Last Comment Bug 716031 - Intermittent chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
: Intermittent chrome://mochitests/content/chrome/editor/libeditor/base/tests/t...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: Editor (show other bugs)
: 12 Branch
: x86 Mac OS X
: -- normal (vote)
: mozilla18
Assigned To: Vladimir Vukicevic [:vlad] [:vladv]
:
Mentors:
Depends on:
Blocks: 438871
  Show dependency treegraph
 
Reported: 2012-01-06 13:07 PST by Ed Morley [:emorley]
Modified: 2012-11-25 19:31 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
This should fix it, I think; fixes things for me in the try pushes where I was seeing this a lot (1.41 KB, patch)
2012-01-14 13:34 PST, Boris Zbarsky [:bz]
ehsan: review+
Details | Diff | Splinter Review
alternate patch, using explicit refresh driver timing (1022 bytes, patch)
2012-10-04 13:51 PDT, Vladimir Vukicevic [:vlad] [:vladv]
vladimir: review+
Details | Diff | Splinter Review

Description Ed Morley [:emorley] 2012-01-06 13:07:04 PST
https://tbpl.mozilla.org/php/getParsedLog.php?id=8265070&tree=Firefox
Rev3 MacOSX Leopard 10.5.8 mozilla-central opt test mochitest-other on https://hg.mozilla.org/mozilla-central/rev/d702c3cf4e4a

9916 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
Comment 1 Treeherder Robot 2012-01-06 14:04:52 PST
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=8360874&tree=Mozilla-Inbound
Rev4 MacOSX Snow Leopard 10.6 mozilla-inbound opt test mochitest-other on 2012-01-05 16:06:19

9948 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
31753 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/widget/tests/test_bug596600.xul | box shouldn't be hovered
Comment 2 Treeherder Robot 2012-01-11 12:15:45 PST
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=8485758&tree=Firefox
Rev4 MacOSX Snow Leopard 10.6 mozilla-central opt test mochitest-other on 2012-01-11 11:18:27

9948 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
Comment 3 Treeherder Robot 2012-01-13 08:00:15 PST
ttaubert
https://tbpl.mozilla.org/php/getParsedLog.php?id=8530865&tree=Fx-Team
Rev4 MacOSX Snow Leopard 10.6 fx-team opt test mochitest-other on 2012-01-13 06:08:45

9948 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
Comment 4 Treeherder Robot 2012-01-13 23:32:23 PST
bz
https://tbpl.mozilla.org/php/getParsedLog.php?id=8543590&tree=Try
Rev3 Fedora 12x64 try opt test mochitest-other on 2012-01-13 22:52:04

10637 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
Comment 5 Treeherder Robot 2012-01-13 23:33:39 PST
bz
https://tbpl.mozilla.org/php/getParsedLog.php?id=8543630&tree=Try
Rev3 WINNT 6.1 try opt test mochitest-other on 2012-01-13 22:47:06

10706 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
Comment 6 Treeherder Robot 2012-01-14 00:57:50 PST
vporof
https://tbpl.mozilla.org/php/getParsedLog.php?id=8540895&tree=Try
Rev4 MacOSX Snow Leopard 10.6 try opt test mochitest-other on 2012-01-13 18:50:52

9948 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
Comment 7 Treeherder Robot 2012-01-14 08:50:52 PST
bz
https://tbpl.mozilla.org/php/getParsedLog.php?id=8544469&tree=Try
Rev3 WINNT 6.1 try opt test mochitest-other on 2012-01-14 00:16:07

10706 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
Comment 8 Treeherder Robot 2012-01-14 08:51:32 PST
bz
https://tbpl.mozilla.org/php/getParsedLog.php?id=8544116&tree=Try
Rev3 WINNT 6.1 try opt test mochitest-other on 2012-01-13 23:32:50

10706 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
Comment 9 Treeherder Robot 2012-01-14 13:34:30 PST
bz
https://tbpl.mozilla.org/php/getParsedLog.php?id=8550929&tree=Try
Rev3 WINNT 6.1 try opt test mochitest-other on 2012-01-14 08:51:33

10706 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollBottom - got 0, expected -300
Comment 10 Boris Zbarsky [:bz] 2012-01-14 13:34:56 PST
Created attachment 588687 [details] [diff] [review]
This should fix it, I think; fixes things for me in the try pushes where I was seeing this a lot
Comment 11 Boris Zbarsky [:bz] 2012-01-14 21:01:33 PST
Pushed as https://hg.mozilla.org/integration/mozilla-inbound/rev/1e0405f18207 in the meantime, because I needed it for something else.
Comment 12 Jonathan Kew (:jfkthame) 2012-01-16 04:46:08 PST
This merged to m-c:
https://hg.mozilla.org/mozilla-central/rev/1e0405f18207

I'm not resolving the bug for now, though, as it's still pending review - not sure how best to handle that.
Comment 13 Boris Zbarsky [:bz] 2012-01-16 08:54:20 PST
I think we should just go ahead and resolve, then file followups if Ehsan has a problem with the patch or reopen if this keeps happening.
Comment 14 Treeherder Robot 2012-05-04 09:45:50 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=11465096&tree=Profiling
Rev4 MacOSX Snow Leopard 10.6 profiling opt test mochitest-other on 2012-05-04 06:33:44
slave: talos-r4-snow-022

10201 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollPageUp - got -300, expected -210
10202 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | Can scroll by lines
Comment 15 Treeherder Robot 2012-05-18 03:09:16 PDT
edmorley
https://tbpl.mozilla.org/php/getParsedLog.php?id=11840749&tree=Fx-Team
Rev3 WINNT 5.1 fx-team debug test mochitest-other on 2012-05-17 11:58:09
slave: talos-r3-xp-009

10456 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | Can scroll by lines
10457 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollLineUp - got -243, expected -300
Comment 16 Treeherder Robot 2012-05-23 07:05:20 PDT
jorendorff
https://tbpl.mozilla.org/php/getParsedLog.php?id=11970986&tree=Try
Rev3 WINNT 5.1 try debug test mochitest-other on 2012-05-22 19:00:07
slave: talos-r3-xp-014

10454 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | Can scroll by lines
10455 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollLineUp - got -243, expected -300
Comment 17 Treeherder Robot 2012-08-25 10:03:57 PDT
paul
https://tbpl.mozilla.org/php/getParsedLog.php?id=14705653&tree=Fx-Team
Rev3 WINNT 6.1 fx-team debug test mochitest-other on 2012-08-25 08:19:46
slave: talos-r3-w7-035

9569 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | Can scroll by lines
9570 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/editor/libeditor/base/tests/test_selection_move_commands.xul | cmd_scrollLineUp - got -243, expected -300
Comment 18 Vladimir Vukicevic [:vlad] [:vladv] 2012-10-04 13:51:37 PDT
Created attachment 668161 [details] [diff] [review]
alternate patch, using explicit refresh driver timing

Alternate/different fix -- drive the refreshdriver directly, which is what is doing the scrolling.  This seems to fix this for me in a pretty bulletproof way; ehsan r+'d it over my shoulder.  May also fix bug 752808 and bug 759254.
Comment 19 Ed Morley [:emorley] 2012-10-06 12:51:43 PDT
https://hg.mozilla.org/mozilla-central/rev/e28ab3e5e961

Note You need to log in before you can comment on or make changes to this bug.