[Firefox Aurora Update] Thank You Page for Aurora

RESOLVED FIXED

Status

Marketing
Design
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: grace, Assigned: Ty Flanagan)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Hi Ty, 

Wanted to add a Thank you page for Aurora. 
It can be pretty similar to what we have for the Thank you Page for GA" http://screencast.com/t/oz5qbbNQC (but aurora branded).

One thing that I want to add in this page.. .is the ability to share via facebook and twitter.

Adding a button that lets you share in facebook and twitter after you download aurora.

not super urgent. please advise on the deadline.
(Reporter)

Comment 1

6 years ago
hi ty, 

since this is not part of the channel branding project, it needs to be treated as a one off request. 

let me know if you have any questions about this bug. 

timing: not tied to any release but would be good to have it in a few weeks. 

thanks!
(Reporter)

Updated

6 years ago
Blocks: 718815

Updated

6 years ago
Status: NEW → ASSIGNED
(Assignee)

Comment 2

6 years ago
Created attachment 589989 [details]
FFx Aurora - Download Thank You Page
(Reporter)

Comment 3

6 years ago
hi ty, 

this page looks great!

One question.. can we add a sharing aspect in the page...
after downloading... get the user to share it on facebook or twitter?

maybe we can have a default copy already and then they can just press the twitter or facebook button to share it? (ie. I downloaded Firefox Aurora. Preview new and upcoming features. Get Aurora now. or something around those lines.)

adding..williamr and matej for copy recommendations. 

also open to recommendations on how we can add sharing from this page.

Comment 4

6 years ago
The copy on this page comes from the Firefox GA thank you page, which plays off the "Different by Design" copy on that download page. I'm not sure we should be using that copy here. Or if so, we should expand on it a bit since users won't be going through that whole experience. Maybe something like:

"Thanks for downloading Firefox Aurora! As a non-profit, we’re free to innovate on your behalf without any pressure to compromise. That means a better experience for you and a brighter future for the Web."

Does that work for people, or should we be even more different here?

Comment 5

6 years ago
(In reply to Ty Flanagan from comment #2)
> Created attachment 589989 [details]
> FFx Aurora - Download Thank You Page

Hi Ty - Do we have a Windows version of this? It's a dynamic page that depends on OS, so that would be needed too. Thanks!

Comment 6

6 years ago
(In reply to Matej Novak [:matej] from comment #4)
> The copy on this page comes from the Firefox GA thank you page, which plays
> off the "Different by Design" copy on that download page. I'm not sure we
> should be using that copy here. Or if so, we should expand on it a bit since
> users won't be going through that whole experience. Maybe something like:
> 
> "Thanks for downloading Firefox Aurora! As a non-profit, we’re free to
> innovate on your behalf without any pressure to compromise. That means a
> better experience for you and a brighter future for the Web."
> 
> Does that work for people, or should we be even more different here?

Agree - I think the headline is good, and thanking them in the line below is good, but let's consider cutting the rest of the brand campaign centric copy since these VIP users don't need to hear more about us. Less copy would also give it a nice clean feel.

Comment 7

6 years ago
(In reply to Grace Jimenez :grace from comment #3)
> hi ty, 
> 
> this page looks great!
> 
> One question.. can we add a sharing aspect in the page...
> after downloading... get the user to share it on facebook or twitter?
> 
> maybe we can have a default copy already and then they can just press the
> twitter or facebook button to share it? (ie. I downloaded Firefox Aurora.
> Preview new and upcoming features. Get Aurora now. or something around those
> lines.)

I have to say, I don't think this is the right spot for that. Let's keep the focus on getting them to download, and getting them to signup for the newsletter within this part of the experience. If you just unwrapped a new toy from it's box, would that be the right time to share it with a friend? I'd think you'd want to play with your toy first, before recommending it. (shoddy metaphor but you get my point - it's too early for that here) 



> adding..williamr and matej for copy recommendations. 
> 
> also open to recommendations on how we can add sharing from this page.

If you'd like to enable sharing, I'd consider using the snippets these users see. A localized "share aurora" snippet campaign could really have a big impact.
(In reply to Laura Forrest from comment #7)
> I have to say, I don't think this is the right spot for that. Let's keep the
> focus on getting them to download, and getting them to signup for the
> newsletter within this part of the experience. If you just unwrapped a new
> toy from it's box, would that be the right time to share it with a friend?
> I'd think you'd want to play with your toy first, before recommending it.
> (shoddy metaphor but you get my point - it's too early for that here) 

Good metaphor. I do think the Firefox for Twitter bundle is a good case study here. Around 50 users/day downloading Firefox from that page click on the Tweet button and share their new toy even before they've tried it. I think it would be worth trying here as it's a similar page. If it doesn't work, we could always remove it.

https://twitter.com/#!/download/firefox/

> If you'd like to enable sharing, I'd consider using the snippets these users
> see. A localized "share aurora" snippet campaign could really have a big
> impact.

I think this is an excellent idea. Also, if there's an Aurora specific firstrun page in the works, that seems like a prime location for users to share their new toy.

Including a sharing CTA to new Aurora newsletter subscribers in a confirmation or welcome email seems like a very appropriate sharing opportunity too. Grace, that would be good for us to talk with Winston and Jess about off-bug.

Comment 9

6 years ago
OK, how about one of these lines to pre-populate the tweet:


I just downloaded Firefox Aurora. Join me in shaping the future of Firefox.

I just downloaded Firefox Aurora to preview and test the latest experimental features and technologies. Get it here:

I just downloaded Firefox Aurora. Get it yourself for a first look at the latest features and experiments.
(Reporter)

Comment 10

6 years ago
thanks matej! 

great copy!

ty, let us know if you have any additional questions here.
(Assignee)

Comment 11

6 years ago
(In reply to Laura Forrest from comment #5)
> (In reply to Ty Flanagan from comment #2)
> > Created attachment 589989 [details]
> > FFx Aurora - Download Thank You Page
> 
> Hi Ty - Do we have a Windows version of this? It's a dynamic page that
> depends on OS, so that would be needed too. Thanks!

I dont have screenshots for WIN XP, VISTA, or 7. I ended up creating editable templates for the OS X screens.

I also took a look at the current FFx Thank You page for Windows clients and there's no screenshots or instructions for them. 

Take a looksy: http://www.mozilla.org/en-US/products/download.html?product=firefox-9.0.1&os=win&lang=en-US
(Reporter)

Comment 12

6 years ago
thanks ty,

I believe we still need to add the share buttons in this page. 
is it possible to get screenshots for the windows? 

do you have everything you need for this page? please let me know if you have any additional questions.

thanks
(Assignee)

Comment 13

6 years ago
With regards to the Windows screenshots, I have requested a laptop with WinXP, Vista, and Win7 installed to take screenshots of the Firefox installs on each respective Windows version.

I wont get the machine till later today though, so ill only have the updated design readied tomorrow, latest Thursday.

Considering we don't have screenshots of the latest GA release for Windows either, we should open a new bug to get the current GA Thank You page updated.
(Reporter)

Comment 14

6 years ago
hi ty, 

thanks for the update.
timing should be fine.
i will also open bug for the GA thank you page (windows). 

thanks!
(Reporter)

Comment 15

6 years ago
hi ty, 

do we have an update with this page?

thanks!
(Assignee)

Comment 16

6 years ago
I now have all the screenshots taken for the different Windows platforms. Ill update the design tomorrow and upload the collection of screenshots we can use. 

Ill need the final step-by-step download copy for Windows users. I can only view what mac users see :(

Comment 17

6 years ago
(In reply to Laura Forrest from comment #7)

> 
> I have to say, I don't think this is the right spot for that. Let's keep the
> focus on getting them to download, and getting them to signup for the
> newsletter within this part of the experience. If you just unwrapped a new
> toy from it's box, would that be the right time to share it with a friend?
> I'd think you'd want to play with your toy first, before recommending it.
> (shoddy metaphor but you get my point - it's too early for that here) 
> 

Laura, +1 for your comments on the user experience. We have lots of opportunities to add social, but the goal of this initial onboarding is to teach/orient the user to a 1-2-3 about the product.

Additionally, we are currently on a short 2-week pause for adding Twitter/Facebook functionality, pending the completion and rollout of a universal Twitter/Facebook solution that will be deployed across all Mozilla sites, including /firefox. I anticipate that it will be available for us by 1.6 - 1.7 at the latest. 

Grace, I'm making a note for us to revisit in a check-in after this page is implemented.
(Reporter)

Comment 18

6 years ago
(In reply to mcbmoz from comment #17)
> (In reply to Laura Forrest from comment #7)
> 
> > 
> > I have to say, I don't think this is the right spot for that. Let's keep the
> > focus on getting them to download, and getting them to signup for the
> > newsletter within this part of the experience. If you just unwrapped a new
> > toy from it's box, would that be the right time to share it with a friend?
> > I'd think you'd want to play with your toy first, before recommending it.
> > (shoddy metaphor but you get my point - it's too early for that here) 
> > 
> 
> Laura, +1 for your comments on the user experience. We have lots of
> opportunities to add social, but the goal of this initial onboarding is to
> teach/orient the user to a 1-2-3 about the product.
> 
> Additionally, we are currently on a short 2-week pause for adding
> Twitter/Facebook functionality, pending the completion and rollout of a
> universal Twitter/Facebook solution that will be deployed across all Mozilla
> sites, including /firefox. I anticipate that it will be available for us by
> 1.6 - 1.7 at the latest. 
> 
> Grace, I'm making a note for us to revisit in a check-in after this page is
> implemented.

Thanks Chrissie!

if the universal twitter/facebook solution is going live in 1.6. I am okay with that. Given that we are still waiting for the design, i anticipate that the earliest this page can go live is 1.6. In which case, I would like to spec the social media aspect in the design now. 

However, if this means that the sharing functionality will not be available to this page for another month, I would suggest potentially adding a simple sharing message. 


On any other cases, I would usually be okay with waiting and going for the ideal situation. 

However, growing Aurora continues to be our goal and a priority for us this quarter.
I would like to test this out to see if it works and evaluate if we see any increase in total number of downloads and eventually adu's

The goal of having the social aspect here, is not get followers on Twitter or facebook, but giving the user who just downloaded the product the opportunity to tweet and share that they just got firefox aurora and potentially reach their followers. 

Since this is a Q1 goal, it would be great to get it rolling. I would hate to risk, miss and potentially roll over this project to the next quarter again. 

fyi. i will be requesting the same for beta.

Comment 19

6 years ago
Hey Grace, 

We don't want to block your efforts to Grow Aurora, rather help guide the user experience and also steward you through some of the more technical details around Mozilla's evolving policy on 3rd party social integration. To that end, I've been working hard with Security, IT, Privacy and Legal, and as mentioned above WebDev is close to deploying a solution in 1.6 or 1.7. I would be happy to discuss what the new options will be with you and LoFo.

For this design and implementation, a direct link to social accounts can be added. LoFo's made important recommendations against cluttering the user experience, and importantly made a very powerful recommendation about where these buttons can be more useful. I look to her to make the final call.
(In reply to mcbmoz from comment #19)
> For this design and implementation, a direct link to social accounts can be
> added.

Given the importance of Growing Aurora and the opportunity for using this page as an engagement point, I think a static link with a tweet message would be reasonable. The Firefox with Twitter example in comment 8 shows this can be done in a clean, uncluttered way and there aren't any security/IT/privacy/legal concerns with a static link [1]. Could we consider this solution for now and then add the universal Twitter/Facebook solution in a month or so when those assets are ready?



[1] Example of a static tweet link: https://twitter.com/intent/tweet?original_referer=http%3A%2F%2Fwww.mozilla.org%2Fen-US%2Ffirefoxlive%2F&related=cubcaretaker&source=tweetbutton&text=What+is+more+endearing%3F+Firefox%E2%80%99s+non-profit+mission+or+a+live+feed+of+their+animal+mascot%3F+Find+out+&url=http%3A%2F%2Fmzl.la%2FsPo5yu&via=firefox

Comment 21

6 years ago
William, thanks so much for adding to this thread. 

Grace, this is a bit of a tricky issue, that we will work on outside of the scope of this bug. It's been helpful to better understand your requirements, I'm confident we'll come to a great outcome. Let's schedule a meeting with LoFo to identify the scope of where you want social sharing in the phase 2 after the first launch.
(Reporter)

Comment 22

6 years ago
Hi, 

Just to confirm, we are okay with adding a static link with a tweet message for now and then revisit this again for phase 2 (after the universal social project is implemented?).

Please let us know so Ty can update the design. 

Thanks!

Comment 23

6 years ago
(In reply to Grace Jimenez :grace from comment #22)
> Hi, 
> 
> Just to confirm, we are okay with adding a static link with a tweet message
> for now and then revisit this again for phase 2 (after the universal social
> project is implemented?).
> 
> Please let us know so Ty can update the design. 
> 
> Thanks!

Grace, for this design and implementation the scope needs to be narrow, so we can have a static image that directly links to the twitter/facebook assets. You can see this in the footer area today "Connect with us, follow us, be friends with us."

In the near future, we'll have something more dynamic that's applied across all pages of the site.

Looks like we just need the PSD here, so we can move over to implementation :-)
(Reporter)

Comment 24

6 years ago
Chrissie, 

I apologize if I am not following you quickly enough, will the static image that directly links to the twitter/facebook asset have the pre-loaded copy? Or does it just link to the Firefox Aurora Facebook Page and Firefox Aurora Twitter page?

How is this different to what we have now "connect with us"?

Thanks again for the clarification.

Comment 25

6 years ago
(In reply to Grace Jimenez :grace from comment #24)
> Chrissie, 
> 
> I apologize if I am not following you quickly enough, will the static image
> that directly links to the twitter/facebook asset have the pre-loaded copy?
> Or does it just link to the Firefox Aurora Facebook Page and Firefox Aurora
> Twitter page?

For this phase of design/implementation we can only support a direct link, no embedded copy (sorry!).

> How is this different to what we have now "connect with us"?

It will be identical to how the "connect with us" graphic directly links to the social asset.

> Thanks again for the clarification.

No problem, it's tricky, but hopefully William and I clarified over email today too. More advanced implementations can be done, but they involve security reviews (additional 14 days), as well as privacy/legal checks. The solution we will be deploying in February for all Mozilla-wide sites will enable us to better support more interaction and direct connection/authentication with social services. Hang tight, you're gonna love we have coming up!

Comment 26

6 years ago
Agree - while I still don't think it's the ideal spot within the UX and threats to make the page unfocused, I'm fine with adding it in and seeing what it does. 

Grace - we'll be looking to you to report out those numbers, as I'm sure we're all very curious! 

Let's get some mockups from Ty to see what this looks like, and then once those are done, this will be ready to pass onto WebDev.
(Assignee)

Comment 27

6 years ago
Created attachment 594259 [details]
FFx Aurora - Download Thank You Page w/ Twitter Buttons

Comment 28

6 years ago
notes for LoFo/Grace:

*good news, this doesn't need to be resized to fit a smartphone screen, because it's a desktop download/flow (mobile happens in the store, so this isn't an experience that needs to be duplicated)

*for implementation we should probably put a "no follow" on this page, so that it doesn't show up in search results and confuse users.

Updated

6 years ago
Blocks: 725545

Comment 29

6 years ago
(In reply to mcbmoz from comment #28)
> notes for LoFo/Grace:
> 
> *good news, this doesn't need to be resized to fit a smartphone screen,
> because it's a desktop download/flow (mobile happens in the store, so this
> isn't an experience that needs to be duplicated)
> 
> *for implementation we should probably put a "no follow" on this page, so
> that it doesn't show up in search results and confuse users.

Good suggested - I added this to the Implementation bug. 

Looks like this page is finished!
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED

Comment 30

6 years ago
Ty - Can you post the final PSD here?
(Reporter)

Comment 32

6 years ago
Hi Ty, 

Finally implementing this page.
Do we have a windows version as well by any chance?

Thanks!
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 33

6 years ago
amg yay!

yes i still have the screengrabs for windows. ill package them up in the AM
(Reporter)

Comment 34

6 years ago
Thanks Ty!
(Assignee)

Comment 35

6 years ago
Hey Grace,

Here are the screengrabs:   
https://www.dropbox.com/s/dgufe9inaa5nt6k/Install_Process_Screengrabs.zip
What's the status of this design? Should we be waiting for another update before implementing?
(Assignee)

Comment 37

6 years ago
Grace, do we need to make any changes to the design? I have a feeling that link to the PSD no longer works though, so ill need to repost it to my dropbox
I'm working on the implementation for this page, and I'm wondering about the installation steps screenshots.  Since this bug was originally filed, these have been removed from the main Firefox download Thank You page (think because it wasn't maintainable for all platforms/locales?). Should they remain in the Aurora version?
(In reply to Steven Garrity from comment #39)
> I'm working on the implementation for this page, and I'm wondering about the
> installation steps screenshots.  Since this bug was originally filed, these
> have been removed from the main Firefox download Thank You page (think
> because it wasn't maintainable for all platforms/locales?). Should they
> remain in the Aurora version?

It turns out we do still have the install steps for Windows and OSX. Disregard my previous comment.

Comment 41

6 years ago
seems like this is long overdue for a close.  please ping or re-open if that's not the case. thanks!
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.