Last Comment Bug 716380 - socket transport n != 0 assertion
: socket transport n != 0 assertion
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: unspecified
: x86_64 Windows 7
: -- normal (vote)
: mozilla12
Assigned To: Patrick McManus [:mcmanus]
:
:
Mentors:
Depends on:
Blocks: 719609
  Show dependency treegraph
 
Reported: 2012-01-08 09:13 PST by Patrick McManus [:mcmanus]
Modified: 2012-01-25 18:06 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
patch 0 (1017 bytes, patch)
2012-01-08 09:20 PST, Patrick McManus [:mcmanus]
honzab.moz: review+
Details | Diff | Splinter Review

Description Patrick McManus [:mcmanus] 2012-01-08 09:13:01 PST
-    NS_ASSERTION(n != 0, "unexpected return value");

is firing when doing ssl handshakes with spdy enabled. (nsSocketTransport2.cpp around 585)

it is checking the PR_Write() return value - 0 is actually fine and expected in this case (where 0 was submitted), I've read through the sockettransport code as well as the nsIOutputStream interface and it shouldn't be a problem.

the error seems to be with the NSPR documentation of PR_Write(). Brian is going to follow up on that one.
Comment 1 Patrick McManus [:mcmanus] 2012-01-08 09:20:50 PST
Created attachment 586813 [details] [diff] [review]
patch 0
Comment 2 Honza Bambas (:mayhemer) 2012-01-25 11:20:26 PST
Comment on attachment 586813 [details] [diff] [review]
patch 0

Review of attachment 586813 [details] [diff] [review]:
-----------------------------------------------------------------

r=honzab

Maybe, do this check/assertion only if count != 0 ?
Comment 3 Patrick McManus [:mcmanus] 2012-01-25 12:42:03 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/a9823c18b423
Comment 4 Ed Morley [:emorley] 2012-01-25 18:06:46 PST
https://hg.mozilla.org/mozilla-central/rev/a9823c18b423

Note You need to log in before you can comment on or make changes to this bug.