Some bookmark.*Cmd are missing an ellipsis

RESOLVED FIXED in seamonkey2.9

Status

defect
--
trivial
RESOLVED FIXED
8 years ago
8 years ago

People

(Reporter: sgautherie, Assigned: InvisibleSmiley)

Tracking

Trunk
seamonkey2.9
Dependency tree / graph
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(1 attachment, 1 obsolete attachment)

[Mozilla/5.0 (Windows NT 5.0; rv:12.0a1) Gecko/20120104 Firefox/12.0a1 SeaMonkey/2.9a1]

bookmarkLinkCmd and bookmarkPageCmd open a dialog: need ellipsis.

I didn't test bookmarkFrameCmd and bookmarkLinksCmd.
Flags: in-testsuite-
Firefox doesn't use ellipsis either for these two items. Perhaps there is some method to the madness?
(In reply to Philip Chee from comment #1)
> Firefox doesn't use ellipsis either for these two items. Perhaps there is
> some method to the madness?

I'm not sure ;-<
I didn't check Firefox. I think ellipsis should be there when there is an associated dialog.
bookmarkLinkCmd has ellipsis in mailnews and history, not in contentarea... though I didn't check how the two former actually behaves.
Duplicate of this bug: 716698
(In reply to Serge Gautherie (:sgautherie) from comment #2)
> (In reply to Philip Chee from comment #1)
> > Firefox doesn't use ellipsis either for these two items. Perhaps there is
> > some method to the madness?
> 
> I'm not sure ;-<
> I didn't check Firefox.

No need to repeat mistakes (IOW: I don't care what FF does).

> I think ellipsis should be there when there is an associated dialog.

!

Reposting what I wrote in bug 716698 (duping this one against it would have been easier I guess):

As found/discussed in bug 224433, some context menu items related to bookmarking miss an ellipsis that indicates that a new window/dialog will open, i.e. the action is not instant. This observation is based on current (trunk) code, i.e. with Places-based bookmarks.

Examples of items and actions:
* Bookmark This Page -> Edit This Bookmark (doorhanger)
* Bookmark This Link -> New Bookmark (dialog)
* Bookmark This Frame -> New Bookmark (dialog)

Note: Bookmarks/Bookmark This Page is a counter-example (it *is* instant).

Entities are defined in (UTF-8) file suite/locales/en-US/chrome/common/contentAreaCommands.dtd:
* bookmarkPageCmd.label
* bookmarkLinkCmd.label
* bookmarkFrameCmd.label

Note 2: The Bookmarks menu uses addCurPageCmd.label from navigatorOverlay.dtd, so we can safely change all of the above entities.

Open question: Do we really need to rename the entities if we only add ellipses?
> Open question: Do we really need to rename the entities if we only add ellipses?
No. But you should post a heads up to the L10n newsgroup.
Posted patch patch (obsolete) — Splinter Review
Assignee: nobody → jh
Status: NEW → ASSIGNED
Attachment #587428 - Flags: review?(neil)
Depends on: 224433
(In reply to Serge Gautherie (:sgautherie) from comment #0)
> I didn't test bookmarkFrameCmd and bookmarkLinksCmd.

To be explicit, did you check bookmarkLinksCmd from history.dtd?
(In reply to Serge Gautherie (:sgautherie) from comment #7)
> (In reply to Serge Gautherie (:sgautherie) from comment #0)
> > I didn't test bookmarkFrameCmd and bookmarkLinksCmd.
> 
> To be explicit, did you check bookmarkLinksCmd from history.dtd?

No. Seems to require an ellipsis, too (opens a New Bookmarks dialog). [STR: Open History window, select multiple page entries, context-click and select Bookmark These Links.] Let's see what Neil says in general; I can easily modify history.dtd at any time (new patch, or even upon check-in).
Comment on attachment 587428 [details] [diff] [review]
patch

Not 100% sure about the Bookmark Page one since presumably you can click the arrow panel away and the bookmark will still be saved...
Attachment #587428 - Flags: review?(neil) → review+
[now with history.dtd, see discussion with Serge]

(In reply to neil@parkwaycc.co.uk from comment #9)
> Not 100% sure about the Bookmark Page one since presumably you can click the
> arrow panel away and the bookmark will still be saved...

Well, yes, but otherwise it's pretty much an OK/Cancel situation - unlike with the equally-named Bookmarks menu item (bah, why oh why this inconsistency?).
Attachment #587428 - Attachment is obsolete: true
Attachment #587498 - Flags: review?(neil)
Attachment #587498 - Flags: review?(neil) → review+
Comment on attachment 587498 [details] [diff] [review]
patch v1a [Checkin: Comment 11]

http://hg.mozilla.org/comm-central/rev/fad5022b0bf7
Attachment #587498 - Attachment description: patch v1a → patch v1a [Checkin: Comment 11]
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.9
You need to log in before you can comment on or make changes to this bug.