Password not filled if username selected from autocomplete suggestions

VERIFIED FIXED in Firefox 13

Status

()

Firefox for Android
General
P3
normal
VERIFIED FIXED
6 years ago
a year ago

People

(Reporter: Camelia Urian, Assigned: wesj)

Tracking

12 Branch
Firefox 14
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox13 verified, firefox14 verified, fennec12+)

Details

Attachments

(1 attachment)

(Reporter)

Description

6 years ago
Build ID: Mozilla/5.0 (Android; Linux armv7l; rv:12.0a1) Gecko/20120108 Firefox/12.0a1 Fennec/12.0a1
Device: Samsung Nexus S
OS: Android 2.3

Steps to reproduce:
1. Login to www.litmus.mozilla.org with several accounts (user & pass) and save passwords for all. 
2. Open a new tab and go to litmus.mozilla.org, select login
3. Start typing username previously saved.
4. Select username from Form Autocomplete Suggestions pop-up.
5. Move focus to the password field.

Expected results:
 The password field should be filled automatically

Actual results:
 The password field is not filled.

Note: 
 - if user name is typed(not selected from suggestions list), then password is field is filled automatically when focus is moved on password field.
Shouldn't you already be signed in by opening another tab and visiting the same site?

Anyhow, signing out, and going to Litmus, tapping sign-in, I see the fields pre-populated with my credentials saved. This works for me.

Can you re-test?

--
Samsung Nexus S (Android 4.0.3)
Mozilla/5.0 (Android; armv7l; rv:12.0a1) Gecko/20120109 Firefox/12.0a1 Fennec/12.0a1
(Reporter)

Comment 2

6 years ago
Aaron, if you sign in and save password for 2 different accounts and sign out, when you go to the login page the fields are not pre-populated.

Updated

6 years ago
Assignee: nobody → wjohnston
tracking-fennec: --- → 12+
Priority: -- → P3
(Assignee)

Comment 3

6 years ago
Created attachment 605881 [details] [diff] [review]
Patch

The loginManager is listening for a DOMAutocomplete event on the input element:

http://mxr.mozilla.org/mozilla-central/source/toolkit/components/passwordmgr/nsLoginManager.js#347

We fired that in XUL here:

http://mxr.mozilla.org/mozilla-central/source/mobile/xul/chrome/content/forms.js#307

Note, if you're like me and try testing this on touch.facebook.com, it won't work because their password field is not an input type="password" until you focus it and start typing.
(Assignee)

Updated

6 years ago
Attachment #605881 - Flags: review?(margaret.leibovic)

Comment 4

6 years ago
Comment on attachment 605881 [details] [diff] [review]
Patch

Good catch!
Attachment #605881 - Attachment is patch: true
Attachment #605881 - Flags: review?(margaret.leibovic) → review+
(Assignee)

Comment 5

6 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/65605fe6063d
https://hg.mozilla.org/mozilla-central/rev/65605fe6063d
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 14
https://hg.mozilla.org/releases/mozilla-aurora/rev/6273daa1141e
status-firefox13: --- → fixed
status-firefox14: --- → fixed

Comment 8

6 years ago
Verified/fixed on:

Aurora Fennec 13.0a2 (2012-03-25)
Nightly Fennec 14.0a1 (2012-03-25)
Device: Samsung Nexus S
OS: Android 2.3.6
Status: RESOLVED → VERIFIED
status-firefox13: fixed → verified
status-firefox14: fixed → verified
You need to log in before you can comment on or make changes to this bug.