Last Comment Bug 716541 - Do not fail build on -Wuninitialized when treating warnings as errors
: Do not fail build on -Wuninitialized when treating warnings as errors
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Build Config (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla12
Assigned To: Mounir Lamouri (:mounir)
:
Mentors:
Depends on: Wuninitialized
Blocks: 703121 903513 903663
  Show dependency treegraph
 
Reported: 2012-01-09 07:26 PST by Mounir Lamouri (:mounir)
Modified: 2014-04-27 00:11 PDT (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch v1 (957 bytes, patch)
2012-01-09 07:26 PST, Mounir Lamouri (:mounir)
mh+mozilla: review+
Details | Diff | Splinter Review

Description Mounir Lamouri (:mounir) 2012-01-09 07:26:07 PST
Created attachment 586990 [details] [diff] [review]
Patch v1
Comment 1 Mounir Lamouri (:mounir) 2012-01-09 07:28:03 PST
This was requested during the discussion in dev-platform.
Comment 2 Daniel Holbert [:dholbert] 2012-01-09 15:36:54 PST
I think this needs s/initialized/uninitialized/

At least, right now when I build with this and FAIL_ON_WARNINGS=1 added in content/smil, I get the following build error when I hit content/smil:
> error: -Werror=initialized: no option -Winitialized

Also, "man g++" confirms that there's no "-Winitialized", but there is "-Wuninitialized"
Comment 3 Daniel Holbert [:dholbert] 2012-01-09 15:53:20 PST
(confirmed locally that s/initialized/uninitialized/ fixes the error mentioned in Comment 2 and allows me to build)
Comment 4 Daniel Holbert [:dholbert] 2012-01-09 15:56:23 PST
Also, it looks like the existing patch (which I think is broken per comment 2 & comment 3) has already landed:
  http://hg.mozilla.org/integration/mozilla-inbound/rev/a477a8579ead
Comment 5 Daniel Holbert [:dholbert] 2012-01-09 15:59:09 PST
Oh, and Mounir pushed a bustage fix after that to do the s/initialized/uninitialized/ already. Cool.  That bustage-fix was:
  http://hg.mozilla.org/integration/mozilla-inbound/rev/c2a85ff814c8
Comment 6 Daniel Holbert [:dholbert] 2012-01-09 20:32:21 PST
I seem to be hitting some weird "undefined symbol" issues on our Mac OS X tinderboxen, which (so far) always happen right after a -Wuninitialized warning is printed out.  I suspect (but am not sure) that it might be due to GCC 4.2 mishandling "-Werror -Wno-error=uninitialized".

Anyway, I filed bug 716787 on that.
Comment 7 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-01-10 01:26:35 PST
https://hg.mozilla.org/mozilla-central/rev/a477a8579ead
Comment 8 Marco Bonardo [::mak] (Away 6-20 Aug) 2012-01-10 01:38:19 PST
and the followup
https://hg.mozilla.org/mozilla-central/rev/c2a85ff814c8

Note You need to log in before you can comment on or make changes to this bug.