Last Comment Bug 716595 - Pressing back button in select form helper popup causes the first option to be selected
: Pressing back button in select form helper popup causes the first option to b...
Status: VERIFIED FIXED
: testcase
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: ARM Android
: P3 normal (vote)
: Firefox 12
Assigned To: Wesley Johnston (:wesj)
:
Mentors:
http://people.mozilla.com/~nhirata/ht...
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-09 10:31 PST by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2012-01-26 17:35 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
11+


Attachments
Patch (974 bytes, patch)
2012-01-24 14:04 PST, Wesley Johnston (:wesj)
margaret.leibovic: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2012-01-09 10:31:44 PST
Steps to reproduce:
- Visit url testcase
- Tap on the first combobox
- Press the Android back button

Expected result:
- Option "Three" stays selected

Actual result:
- Option "One" becomes selected
Comment 1 Wesley Johnston (:wesj) 2012-01-24 14:04:03 PST
Created attachment 591264 [details] [diff] [review]
Patch

We return -1 here, and then we're trying to deselect everything in the list. This just makes us bail (no changes) when we get -1.
Comment 2 :Margaret Leibovic 2012-01-24 15:42:06 PST
Comment on attachment 591264 [details] [diff] [review]
Patch

It's confusing that FormAssistant.show is only used for select elements. Maybe we can clean up FormAssistant at some point, but that's obviously not a priority right now.
Comment 4 :Ms2ger (⌚ UTC+1/+2) 2012-01-25 07:14:40 PST
https://hg.mozilla.org/mozilla-central/rev/f9b12afb9724
Comment 5 Wesley Johnston (:wesj) 2012-01-25 09:52:04 PST
Comment on attachment 591264 [details] [diff] [review]
Patch

[Approval Request Comment]
Regression caused by (bug #): bug 695485
User impact if declined: potential data loss and annoyance
Testing completed (on m-c, etc.): landed jan 24
Risk to taking this patch (and alternatives if risky): low risk, uses a feature i already built but apparently didn't hook up
Comment 6 Martijn Wargers [:mwargers] (not working for Mozilla) 2012-01-25 10:22:45 PST
Verified fixed in current Native trunk build.
Comment 7 Alex Keybl [:akeybl] 2012-01-25 17:03:54 PST
Comment on attachment 591264 [details] [diff] [review]
Patch

[Triage Comment]
Mobile only - approved for Aurora.
Comment 8 Matt Brubeck (:mbrubeck) 2012-01-26 17:35:13 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/3b0f39cd9d20

Note You need to log in before you can comment on or make changes to this bug.