Last Comment Bug 716607 - Add .pm, .wf, .yt to PSL
: Add .pm, .wf, .yt to PSL
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking: Domain Lists (show other bugs)
: Trunk
: x86_64 Windows Vista
: -- normal (vote)
: mozilla14
Assigned To: Gervase Markham [:gerv]
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-09 10:58 PST by Peter Kasting
Modified: 2012-03-21 03:53 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Diff Supplied directly from AFNIC (1.11 KB, patch)
2012-01-09 13:34 PST, Jothan Frakes
no flags Details | Diff | Review
Patch v.2 (1.16 KB, patch)
2012-03-06 03:01 PST, Gervase Markham [:gerv]
pkasting: review+
Details | Diff | Review

Description Peter Kasting 2012-01-09 10:58:04 PST
These are old domains but apparently registration for them opened in December 2011 (?), so we should add PSL entries.

I haven't done enough research yet to write an actual patch.
Comment 1 Jothan Frakes 2012-01-09 11:14:29 PST
Thanks Peter.  I have been in touch with registry and we have these submitted from them directly.
Comment 2 Jothan Frakes 2012-01-09 13:34:27 PST
Created attachment 587106 [details] [diff] [review]
Diff Supplied directly from AFNIC

This was submitted to us from AFNIC, the registry.
Comment 4 Peter Kasting 2012-01-09 13:38:23 PST
Comment on attachment 587106 [details] [diff] [review]
Diff Supplied directly from AFNIC

There are some problems with this diff.

Minor: "TLD is opened since date" is useless commentary that shouldn't be in the file.

More major: The link on all three is a PR article, not a policy document, the homepage for the registrar, or some other encyclopedic resource.  Worse, this document merely says these domains are "subject to the same rules as FR" but our PSL entry for FR shows many domains in addition to just "fr".  So the waters are muddy on what's actually supported.
Comment 5 Jothan Frakes 2012-01-09 13:53:33 PST
I'll tighten this up.
Comment 6 Gervase Markham [:gerv] 2012-02-21 09:02:59 PST
Jothan: were you able to get more details here?

Gerv
Comment 7 Gervase Markham [:gerv] 2012-03-05 03:49:01 PST
pkasting: what should we do here? Half a loaf is better than no bread; should we stick the base domains into the list to help Chrome, and refine the entries as and when we get more of an idea of what the substructure is?

Gerv
Comment 8 Peter Kasting 2012-03-05 14:04:51 PST
I'm not opposed to checking in the base domains with comments noting that the actual policies are unclear and we probably need a more authoritative list.
Comment 9 Gervase Markham [:gerv] 2012-03-06 03:01:00 PST
Created attachment 603213 [details] [diff] [review]
Patch v.2

Here's a diff with improved formatting and links to a more authoritative document. As far as I can see, these domains have no sub-structure.

Gerv
Comment 10 Peter Kasting 2012-03-08 14:37:27 PST
Comment on attachment 603213 [details] [diff] [review]
Patch v.2

Looks good
Comment 11 Gervase Markham [:gerv] 2012-03-20 08:05:26 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/edfcadccf600

Gerv
Comment 12 Mounir Lamouri (:mounir) 2012-03-21 03:53:44 PDT
https://hg.mozilla.org/mozilla-central/rev/edfcadccf600

Note You need to log in before you can comment on or make changes to this bug.