Last Comment Bug 716702 - jsopcode.h:661:5: warning: C++ style comments are not allowed in ISO C90
: jsopcode.h:661:5: warning: C++ style comments are not allowed in ISO C90
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: x86_64 Linux
: -- normal (vote)
: mozilla12
Assigned To: Daniel Holbert [:dholbert]
:
Mentors:
Depends on:
Blocks: buildwarning 687134
  Show dependency treegraph
 
Reported: 2012-01-09 14:55 PST by Daniel Holbert [:dholbert]
Modified: 2012-01-10 01:57 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
fix (729 bytes, patch)
2012-01-09 14:58 PST, Daniel Holbert [:dholbert]
bhackett1024: review+
Details | Diff | Splinter Review

Description Daniel Holbert [:dholbert] 2012-01-09 14:55:30 PST
Filing bug on this build warning, which we get many copies of (since this header seems to be include in a lot of files):
{
jsopcode.h:661:5: warning: C++ style comments are not allowed in ISO C90 [enabled by default]
jsopcode.h:661:5: warning: (this will be reported only once per input file) [enabled by default]
}

This warning is for this line:
> 663    // Boolean conversion, for 'if (counters) ...'
http://mxr.mozilla.org/mozilla-central/source/js/src/jsopcode.h#663
which was added in http://hg.mozilla.org/mozilla-central/rev/de66e7bd2b98 for bug 687134.
Comment 1 Daniel Holbert [:dholbert] 2012-01-09 14:58:36 PST
Created attachment 587167 [details] [diff] [review]
fix

This changes the comment to be /* .... */ instead of //

though I seem to recall JS engine preferring this style:
 /*
  * comment
  */
Happy to change it to that form if that's better; just let me know.
Comment 2 Daniel Holbert [:dholbert] 2012-01-09 15:47:10 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/7dde51205d24
Comment 3 Marco Bonardo [::mak] 2012-01-10 01:57:19 PST
https://hg.mozilla.org/mozilla-central/rev/7dde51205d24

Note You need to log in before you can comment on or make changes to this bug.