Saving files causes line breaks in tags' alt="" and title=""

NEW
Unassigned

Status

7 years ago
3 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

SeaMonkey 2.5 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

7 years ago
Created attachment 587202 [details]
alt-image-line-breaks.html

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:9.0.1) Gecko/20111221 Firefox/9.0.1 SeaMonkey/2.6.1
Build ID: 20111221001913

Steps to reproduce:

Simply saving files in Composer causes a line break separation in the title="" of anchor tags and the alt="" of image tags.


Actual results:

In the attached example notice how the alt="Great Mother, (the primordial Creatress), Nurturance and Nourishment from the Divine" and all other such attributes are split, resulting not only in line breaks, but also in a lot of space added between the end of one line and the beginning of the next, i.e.

"Imix:
Great Mother,
(the
primordial
Creatress),
Nurturance and
Nourishment
from the
Divine."


Expected results:

With both title and alt attributes, the content between "" should remain contiguous, not altered as such.
(Reporter)

Comment 1

7 years ago
Although the attached file only provides examples of the alt attribute, the same thing consistently occurs with title attributes as well.
(Reporter)

Comment 2

7 years ago
When the line breaks and spaces in the attribute text are removed using Composer, they are renewed when the file is saved again. However, when they are removed using a simple text editor (e.g. Notepad or Wordpad), they do not reoccur when the file's saved - until the file is opened in Composer and thereby saved again.

Comment 3

7 years ago
Wow, this is weird. CC Ehsan in case he has any clues.

Comment 4

7 years ago
This might be something that our serializers do, or it might be SeaMonkey itself.  I don't really know how it saves files...
The serializer probably just inserts line breaks in any sufficiently-long attribute value....

Updated

7 years ago
Duplicate of this bug: 691977

Comment 7

7 years ago
Confirming on trunk
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:16.0) Gecko/16.0 Firefox/16.0 SeaMonkey/2.13a1
Build identifier: 20120712003002
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 7 → All
Hardware: x86_64 → All
Version: SeaMonkey 2.6 Branch → Trunk

Updated

7 years ago
Duplicate of this bug: 716737

Updated

7 years ago
Duplicate of this bug: 581787

Updated

3 years ago
Duplicate of this bug: 1049335

Comment 11

3 years ago
Already  REPRODUCIBLE with  DE  SeaMonkey 2.5  (Windows NT 6.1; WOW64; rv:8.0.1)  Gecko/20111121  Firefox/8.0.1   Build 20111121045514  (Classic Theme) on German WIN7 64bit

Was still ok with  DE  SeaMonkey 2.0  (Windows NT 6.1; WOW64; rv:1.9.1.4)  Gecko/20091017  Build 20091017081335  (Classic Theme) on German WIN7 64bit
Version: Trunk → SeaMonkey 2.5 Branch
You need to log in before you can comment on or make changes to this bug.