Last Comment Bug 716754 - Crash when accessing navigator.mozTelephony from chrome page
: Crash when accessing navigator.mozTelephony from chrome page
Status: RESOLVED FIXED
: crash
Product: Core
Classification: Components
Component: DOM: Device Interfaces (show other bugs)
: Trunk
: All All
: -- critical (vote)
: mozilla12
Assigned To: Ben Turner (not reading bugmail, use the needinfo flag!)
:
: Andrew Overholt [:overholt]
Mentors:
Depends on:
Blocks: webtelephony
  Show dependency treegraph
 
Reported: 2012-01-09 17:56 PST by Philipp von Weitershausen [:philikon]
Modified: 2012-01-12 11:05 PST (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch, v1 (1.39 KB, patch)
2012-01-10 07:47 PST, Ben Turner (not reading bugmail, use the needinfo flag!)
bent.mozilla: review+
Details | Diff | Splinter Review
Patch, v2 (3.47 KB, patch)
2012-01-11 14:49 PST, Ben Turner (not reading bugmail, use the needinfo flag!)
jonas: review+
Details | Diff | Splinter Review

Description Philipp von Weitershausen [:philikon] 2012-01-09 17:56:30 PST
Right now we crash in NS_NewTelephony() if the page accessing navigator.mozTelephony is a chrome page because document->NodePrincipal()->GetURI() returns a null URI (the principal is the system principal).
Comment 1 Philipp von Weitershausen [:philikon] 2012-01-10 01:02:52 PST
I wouldn't say there's anything critical about this since (a) navigator.mozTelephony is not part of any normal Firefox build and (b) B2G's Gaia UI doesn't use chrome at all.
Comment 2 Scoobidiver (away) 2012-01-10 01:10:45 PST
Criticality and priority are two different things.
Comment 3 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-01-10 07:47:24 PST
Created attachment 587316 [details] [diff] [review]
Patch, v1

This has r=sicking.
Comment 4 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-01-11 14:49:36 PST
Created attachment 587842 [details] [diff] [review]
Patch, v2

We decided to allow chrome access always.
Comment 5 Ben Turner (not reading bugmail, use the needinfo flag!) 2012-01-11 18:23:44 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/4abbedf5b4ca
Comment 6 Matt Brubeck (:mbrubeck) 2012-01-12 11:05:07 PST
https://hg.mozilla.org/mozilla-central/rev/4abbedf5b4ca

Note You need to log in before you can comment on or make changes to this bug.