Last Comment Bug 716760 - "Pair device" string addition
: "Pair device" string addition
Status: RESOLVED FIXED
: late-l10n
Product: Android Background Services
Classification: Client Software
Component: Android Sync (show other bugs)
: unspecified
: ARM Android
: -- normal
: mozilla12
Assigned To: Richard Newman [:rnewman]
:
:
Mentors:
Depends on:
Blocks: 721271
  Show dependency treegraph
 
Reported: 2012-01-09 18:31 PST by Richard Newman [:rnewman]
Modified: 2013-04-04 13:48 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
fixed


Attachments
Proposed patch. v1 (2.21 KB, patch)
2012-01-09 18:33 PST, Richard Newman [:rnewman]
blassey.bugs: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description Richard Newman [:rnewman] 2012-01-09 18:31:50 PST
I'd like to get a small change landed now, so we can get it neatly into Aurora and into the hands of localizers.
Comment 1 Richard Newman [:rnewman] 2012-01-09 18:33:31 PST
Created attachment 587223 [details] [diff] [review]
Proposed patch. v1

Feel free to throw this at someone else if I picked the wrong reviewer!
Comment 2 Richard Newman [:rnewman] 2012-01-09 20:46:55 PST
Thanks blassey!

Will flag for Aurora approval once this hits a green m-c.

https://hg.mozilla.org/integration/mozilla-inbound/rev/01d69766026d
Comment 3 Marco Bonardo [::mak] 2012-01-10 02:00:08 PST
https://hg.mozilla.org/mozilla-central/rev/01d69766026d
Comment 4 Richard Newman [:rnewman] 2012-01-10 08:59:04 PST
Comment on attachment 587223 [details] [diff] [review]
Proposed patch. v1

[Approval Request Comment]
Regression caused by (bug #):
* No regression; new Java-only mobile strings.

User impact if declined:
* Delayed l10n time. This has to land *eventually*, so trying for sooner rather than later. No user impact yet.

Testing completed (on m-c, etc.):
* Builds. (Android builds fail if strings aren't a-ok.)

Risk to taking this patch (and alternatives if risky):
* Negligible.
Comment 5 Alex Keybl [:akeybl] 2012-01-11 13:45:18 PST
Comment on attachment 587223 [details] [diff] [review]
Proposed patch. v1

[Triage Comment]
Mobile string freeze is coming up, so approving for Aurora now that this has baked on m-c for a couple of days.
Comment 6 Richard Newman [:rnewman] 2012-01-11 13:51:27 PST
> Mobile string freeze is coming up, so approving for Aurora now that this has
> baked on m-c for a couple of days.

Thanks Alex.

Can't land this until the first Android Sync drop lands (Bug 709391). If that doesn't happen, I guess it'll go in the *second* Android Sync drop, which will implicitly include the first and this change.

In the holding area it goes! :D
Comment 7 Axel Hecht [:Pike] 2012-01-30 07:36:09 PST
Richard, is this out of hold? And if so, does this still need to land?
Comment 8 Richard Newman [:rnewman] 2012-01-30 11:11:24 PST
(In reply to Axel Hecht [:Pike] from comment #7)
> Richard, is this out of hold? And if so, does this still need to land?

We got approval for Aurora last week, so I landed everything in one go. Thanks for the catch! (I guess I need to spend time putting together some Bugzilla queries for "things that need attention"...)
Comment 9 Richard Newman [:rnewman] 2012-01-30 12:54:59 PST
Verified:

$ diff ~/moz/hg/mozilla-aurora/mobile/android/base/locales/en-US/sync_strings.dtd ~/moz/hg/mozilla-central/mobile/android/base/locales/en-US/sync_strings.dtd
20c20
< <!ENTITY sync.link.advancedsetup.label 'Advanced setup...'>
---
> <!ENTITY sync.link.advancedsetup.label 'Advanced setup…'>

which is Bug 721305.

Note You need to log in before you can comment on or make changes to this bug.