Last Comment Bug 716818 - potential race condition in GeckoThread
: potential race condition in GeckoThread
Status: RESOLVED FIXED
[inbound]
:
Product: Firefox for Android
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Mac OS X
-- normal (vote)
: Firefox 12
Assigned To: Brad Lassey [:blassey] (use needinfo?)
:
: Sebastian Kaspari (:sebastian)
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-10 00:04 PST by Brad Lassey [:blassey] (use needinfo?)
Modified: 2012-01-16 22:33 PST (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
fixed
fixed


Attachments
patch (1.92 KB, patch)
2012-01-10 00:04 PST, Brad Lassey [:blassey] (use needinfo?)
mark.finkle: review+
akeybl: approval‑mozilla‑aurora+
Details | Diff | Splinter Review

Description User image Brad Lassey [:blassey] (use needinfo?) 2012-01-10 00:04:36 PST
Created attachment 587255 [details] [diff] [review]
patch

mBrowserToolbar initialized isn't created until after the GeckoThread is created and started, but it is used in GeckoThread.run().
Comment 1 User image Brad Lassey [:blassey] (use needinfo?) 2012-01-10 14:35:49 PST
https://hg.mozilla.org/integration/mozilla-inbound/rev/e10473f947bf
Comment 2 User image Brad Lassey [:blassey] (use needinfo?) 2012-01-10 14:37:30 PST
Comment on attachment 587255 [details] [diff] [review]
patch

[Approval Request Comment]
Regression caused by (bug #): 
User impact if declined: 
very slight possibilty that mBrowserToolbar will be null when its used in GeckoThread
Testing completed (on m-c, etc.): 
on inbound now
Risk to taking this patch (and alternatives if risky):
Fairly low risk, just re-ordering code
Comment 3 User image Alex Keybl [:akeybl] 2012-01-11 13:41:35 PST
Leaving in the queue until this has landed on m-c and baked for a day.
Comment 4 User image Ed Morley [:emorley] 2012-01-11 18:22:08 PST
https://hg.mozilla.org/mozilla-central/rev/e10473f947bf
Comment 5 User image Alex Keybl [:akeybl] 2012-01-12 22:29:58 PST
Comment on attachment 587255 [details] [diff] [review]
patch

[Triage Comment]
Mobile only - approving for Aurora.
Comment 6 User image Mark Finkle (:mfinkle) (use needinfo?) 2012-01-16 22:33:11 PST
https://hg.mozilla.org/releases/mozilla-aurora/rev/42991a0d76fb

Note You need to log in before you can comment on or make changes to this bug.