Remote media not cached properly when requested by flash object

RESOLVED INVALID

Status

()

Firefox
Untriaged
RESOLVED INVALID
6 years ago
6 years ago

People

(Reporter: colemarc, Unassigned)

Tracking

9 Branch
x86
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0
Build ID: 20111104165243

Steps to reproduce:

http://colm.tk/micalizzi-cama/webplayer.yahooapis.html
The above page is a test for Yahoo Webplayer.



Actual results:

No problems in Windows 7 x86 + Firefox 8.0 +  Flash 10.0.32.18.
The problem with Windows 7 x64 + Firefox 9.0.1 +  Flash 10.0.32.18 is:
when I hit F5 to refresh the page, the player is unable to load the remote media files which were played before the refresh. Refreshing again with shift+reload makes no difference. If I clear the cache via Tools>Options>Privacy... then the problem disappears, but only until I refresh again with F5.

Right after the problem happened I pasted the full http address of the problematic media file directly into a new tab address box, and Firefox gives an error like "file not found".

I used "Live HTTP headers" add-on to analyze the http messages. It seems that Firefox thinks the remote file is cached, because it asks the server about modifications after a certain datetime, then the server returns no modifications and Firefox says "file not found". Of course the remote file is in place, it loads correctly after clearing the cache.

The same behaviour is observed with another player (http://colm.tk/micalizzi-cama/xspf_player.html) therefore I think the problem is related to Firefox+Flash.



Expected results:

Firefox 9.0.1 should cache the remote file, otherwise it should not cache it and ask for the remote file instead of asking for modifications.
(Reporter)

Updated

6 years ago
(Reporter)

Comment 1

6 years ago
Problem does not happen on Windows XP SP3 32bit + Firefox 9.0.1 + Flash 10.1.53.64.
Have to test Flash 10.1.53.64 on the original machine to see if problem is version dependent.
(Reporter)

Comment 2

6 years ago
Sorry, I was wrong about the Flash version.
The problematic combination is: Windows 7 x64 + Firefox 9.0.1 +  Flash 11.1.102.55.

The important thing is that the problem disappeared when I restarted Firefox in safe mode.
Then I disabled the extensions (add-ons) one at a time and found that the problem depends on Flashgot 1.3.6 being enabled. I double checked it by enabling Flashgot again: the problem reappeared.

I can confirm that in the machines not affected by the problem there is no Flashgot, so definitely this is a Flashgot matter.
(Reporter)

Comment 3

6 years ago
Resolved upgrading Flashgot to 1.3.7.
See http://forums.informaction.com/viewtopic.php?f=6&t=7935&sid=dbf1f9961fa4c5e2a2eb79456be02c4b
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.