As said in bug 674726, |active| was too vague and |activeCall| should be used instead. See bug 674726 comment 52 and bug 674726 comment 53.
Sorry, I forgot to comment there, sicking and I decided that it has to stay 'active' because soon it may contain a group (conference call), not just a call.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
How is a conference call not a call?
It's not a Call object though.
(In reply to Jonas Sicking (:sicking) from comment #3) > It's not a Call object though. I'm not sure it really matters actually. Though, it seems weird to have a object representing a conference call that hasn't 'Call' in his name. Is the interface specified somewhere?
We haven't defined multi-part calls yet so there's nothing written. I suspect we'll call it something like CallGroup which indeed has "call" in the name. As a general principle I don't care too deeply about names, so I'm happy to let you guys fight this one out.
(In reply to Jonas Sicking (:sicking) from comment #5) > As a general principle I don't care too deeply about names, so I'm happy to > let you guys fight this one out. Good names make good APIs and here |active| is too vague. The first though of any caller would be that |foo.active| means "is |foo| active?". However, it would return the active call. Thinking about it twice would probably make the caller understand. However, we want everyone to understand everything clearly and quickly I believe.
You guys are allowed to say I'm a bit stubborn :)
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
Not blocking the release.
blocking-basecamp: --- → -
https://bugzilla.mozilla.org/show_bug.cgi?id=1472046 Move all DOM bugs that haven’t been updated in more than 3 years and has no one currently assigned to P5. If you have questions, please contact :mdaly.
Priority: -- → P5
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.